WS 2012 R2 Essentials - porty 80 a 443 - digest autentizace?

Diskuze k serverovým edicím Microsoft Windows

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod bajlek 11. 8. 2014 22:38

Dobrý den, mám problém se serverem a rád bych poprosil o pomoc....

HW konfigurace: HP DL380e Gen8, HW řadič B320i RAID 1 (disky 2x SATA III), 12GB RAM, 4x NIC sdružená do jednoho virtuálního LAN, 1x NIC pro iLO4

OS a služby: Windows Server 2012 R2 Essentials x64, primární a jediný řadič domény, doménoví uživatelé, DNS, IIS 7.5, NAP, AD, WSUS, tiskové a souborové služby, SQL Server Express 2008/2012/2014

SW: Pohoda SQL Komplet, PowerKey (docházka), síťové tiskárny s sw EPSON/SAMSUNG/OKI, AVG Bussiness + AVG admin, HP SW, PSS (nějaký soft na NVR pro IP kamery)

Systém mám zálohovaný,ale mám pouze 11 verzí zálohy OS (osobně pochybuji, že se něco za posledních 14 dní stalo - nic se totiž neinstalovalo, neaktualizovalo atd...).

MŮJ PROBLÉM
Nefunguje software od MS pro připojení klienta do domény (asi kvůli -> viz. dále).

Při zadání http://127.0.0.1 na serveru nebo IP adrese či hostname serveru naskočí tabulka pro zadání jména a hesla a to NEMÁ. Vše je od počátku nastaveno na anonymous tzn. ihned vidím stránku a ne digest ověřování. Zjistil jsem ale také, že když IIS zastavím, tak vidím stále stejnou stejnou chybu.

Na portu *:80 a *:443 v IIS nemohu nic spustit (port již používá jiná aplikace).

Pokud zadám do přihlašovací tabulky na 127.0.0.1 náhodné údaje tak neprojde a čeká na jiné, když zadám své přihlašovací jméno a heslo tak projde ale nevidím nic než blank page bez kódu.

Kód: Vybrat vše
C:\Users\user>netstat -aon | findstr :80
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       4
  TCP    [::]:80                [::]:0                 LISTENING       4

PID 4 je samosebou systém...

Zkoušel jsem na několik návodů jak opravit digest autentizaci a nahodit zpět anonymní přístup,ale vždy skončím na tom, že anonymní je nastavený :-D

Pomocí currports a tcpview jsem zjistil velký počet naslouchání a zvláštních portů - infekce?

Moje otázka - našla by se tady dobrá duše, která by mi poradila, jak vystopovat odkud přichází ta povinnost na přihlašování (asi z jaké aplikace)? Vše co jsem mohl jsem odinstaloval (myslím sw ne role nebo funkce)

Snad jsem vypsal vše potřebné, v případé potřeby samozřejmě info doplním
bajlek
Junior
Uživatelský avatar

Odeslat příspěvekod michalli 12. 8. 2014 04:58

Psal jsi
Na portu *:80 a *:443 v IIS nemohu nic spustit (port již používá jiná aplikace).

co tedy očekáváš? nebo co se ti nezdá? z toho co jsi psal, by ten přihlašovací dialog měl být od té jiné aplikace ...
dál co se možná hodí je - zda ta druhá aplikace podporuje scénář provozu sama sebe spolu s IIS na tomtéž serveru? pokud ne, tak pak o tom IIS nemusí vědět a může si porty uzurpovat pro sebe (co jsem tak četl dělá to docela běžně, ale nemám vlastní zkušenost).

dále píšeš o tvém hlavním problému
Nefunguje software od MS pro připojení klienta do domény (asi kvůli -> viz. dále).

aniž by jsi popsal jak se problém projevuje, chybové hlášky, apod. ... souviset to spolu může, ale i nemusí.
Michal Zobec
Senior IT Consultant, ZOBEC Consulting
michalli
Junior
Uživatelský avatar

Odeslat příspěvekod Milanr1 12. 8. 2014 07:34

Co řešíš? :-)
bajlek píše:Systém mám zálohovaný

=> obnova OS ze zálohy:
Kód: Vybrat vše
wbadmin

Aplikace testuj ve zkušebních virtuálech, ne v ostrém serveru.
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod bajlek 12. 8. 2014 10:07

Systém mám zálohovaný,ale mám pouze 11 verzí zálohy OS (osobně pochybuji, že se něco za posledních 14 dní stalo - nic se totiž neinstalovalo, neaktualizovalo atd...).
bajlek
Junior
Uživatelský avatar

Odeslat příspěvekod Milanr1 12. 8. 2014 10:11

Zbytečně opakuješ svůj ničím nepodložený (čti: nesmyslný) názor.
Kdyby se nic nestalo, nedošlo by k závadě.
Co s tím?
Pročti si ještě jednou rady Michala, především prostuduj:
michalli píše: chybové hlášky

v Admin logu dále Security log, zda nedošlo k hacku IIS nebo celého OS (podle Tvého zmateného popisu to tak vypadá).
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod bajlek 12. 8. 2014 10:29

michalli píše:Psal jsi
co tedy očekáváš? nebo co se ti nezdá? z toho co jsi psal, by ten přihlašovací dialog měl být od té jiné aplikace ...


MS Connector server vidí v seznamu,ale při snaze se připojit (pokračovat v průvodci dále) vyhodí pro mě neznámou chybu bez identifikátoru, nebo čehokoliv jak by se chyba dala odstranit.

Ano, nemám podloženo, že chyba MS Connectoru souvisí s IIS a dalšími problémy.

Mohu poslat výpis nainstalovaných programů a služeb,ale já v nich nenaŠel nic (Tomcat, Apache apod věci) co by bránili spuštění na portech 80 a 443. SW od HP používá zcela jiné porty (2381), sw pro kamery pouziva 8080 (a hlavne je kamerovy system v jinem subnetu)

-- 12. 8. 2014 09:30 --

Milanr1 píše:Zbytečně opakuješ svůj ničím nepodložený (čti: nesmyslný) názor.
Kdyby se nic nestalo, nedošlo by k závadě.
Co s tím?
Pročti si ještě jednou rady Michala, především prostuduj:
michalli píše: chybové hlášky

v Admin logu dále Security log, zda nedošlo k hacku IIS nebo celého OS (podle Tvého zmateného popisu to tak vypadá).


OK, takže jinak. Tyto vlastnosti (funkce) které popisuji, že nefungují jsem kontroloval naposledy 3 měsíce zpět. A tak daleko prostě zálohy nemám. Do logů se podívám

-- 12. 8. 2014 09:54 --

po vypnutí DNS a IIS mám stále něco na portu 80 a 443 a maskuje se to pod systémem, system explorer nevidí nic

výpis z tcpview
Kód: Vybrat vše
System   4   TCP   SERVER   http   SERVER   0   LISTENING                              
System   4   TCP   SERVER   https   SERVER   0   LISTENING                              
bajlek
Junior
Uživatelský avatar

Odeslat příspěvekod michalli 12. 8. 2014 11:00

takže na jakých portech běží Tomcat a Apache?

to že ti někdo hackl server, toho bych se nebál. abych pochopil, ten SW používáš už delší dobu? tzn. delší dobu než ty tři měsíce co ti naposledy fungovalo přidání další stanice?

chápu dobře že MS Connectorem myslíš průvodce pro přidání stanice/notebooku do domény? já mám poslední zkušenosti se SBS 2011, Essentials systémy už vůbec neznám.
Michal Zobec
Senior IT Consultant, ZOBEC Consulting
michalli
Junior
Uživatelský avatar

Odeslat příspěvekod bajlek 12. 8. 2014 11:07

to je právě to Tomcat ani Apache na serveru neběží. kdyby nějaká aplikace běžela a blokovala porty 80 a 443 tak má vlastní PID. A ano na serverech se za poslední 3 měsíce instalovala pouze Pohoda SQL a PowerWalker na monitoring UPS (který je teď odinstalován).

Ano myslíš zcela správně jedná se o SW pro připojení PC do domény.

A opět správně - nevím proč na mě skáče okno s žádostí o přihlašovací údaje na 127.0.0.1:80 nebo https://127.0.0.1:443 (s certifikátem pro firmaXXX.remotewebaccess.com)

Po zadání svých údajů (administrátorský účet) vidím blank page bez kódu. Chcete screeny?

Poslední stanici (notebook) jsem přidával 12.2.2014 - takže je to déle než jsem si myslel :_(
bajlek
Junior
Uživatelský avatar

Odeslat příspěvekod Milanr1 12. 8. 2014 11:15

Michal:
http://www.microsoft.com/cs-cz/server-c ... x?nv1if1=1
Essentials = prostě levná (čti: drasticky funkčně ořezaná) edice WS 2012 R2.
=> veškeré technické postupy jsou totožné s plnohodnotnými edicemi, jen některé role a vlastnosti nejsou dostupné.

Bajlek:
Porty 80 a 443 mohou okupovat systémové služby, např.:
WinRM
Spooler
HTTP
apod.
Předpokládám, že jsi připojený k serveru standardně pomocí rdp.

Co s tím?
Dočasně zastav a zakaž tyto služby (postupně po jedné), např.:
Kód: Vybrat vše
sc stop http
sc config http start= disabled

a restartuj OS.
Poté znovu:
bajlek píše:netstat -aon

Tak nejrychleji eliminuješ nekorektně nastavené systémové služby jakožto pachatele uvedených potíží.

Btw:
odinstalacím nevěřím:
bajlek píše: PowerWalker na monitoring UPS (který je teď odinstalován).

Prověř, zda neběží příslušná služba.
Naposledy upravil Milanr1 dne 12. 8. 2014 13:13, celkově upraveno 1
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod michalli 12. 8. 2014 12:58

Milane, já jsem tím myslel, že nemám zkušenosti v praxi, vím co jsou systémy Essentials.
Michal Zobec
Senior IT Consultant, ZOBEC Consulting
michalli
Junior
Uživatelský avatar

Odeslat příspěvekod bajlek 12. 8. 2014 23:33

takže aktualizace...
zjistil jsem, že když zakážu http službu tak ihned po nalogování řve systém neočekávanou chybu a podle PID jsem zjistil, že jde o samsung eco driver. jakmile jsem jej killnul, tak na 127.0.0.1:80 nic neběží (IIS default web mám teď na :81 a :8443). odinstalace tiskárny, ovladačů a veškerého SW samsung nepomohla protože v C:\WINDOWS\system32\ jsou stále ještě 3 soubory, které když přesunu tak řve sheduler :-/ takže musím najít položky v plánovači úloh a zrušit je ale nějak se nemohu dopátrat

//edit 13.8.2014 0:21
podarilo se mi v registrech najit rundll32 se spoustenim samsung eco driver, zrusil jsem jej a vse v registrech co se tykalo samsung tiskarny (nebylo jiz ale potreba) - udelal jsem si samozrejme zalohy registru atd. nahodil jsem opet sluzbu http a nastavil spousteni na auto a nyni IIS jede jak ma.

otestovat MS connector nyni nemohu protoze PC je vypnuti prez zasuvku takze jej nevzbudim ani pomoci WOL. dalsi informace dnes ale az okolo 13.hodiny
bajlek
Junior
Uživatelský avatar

Odeslat příspěvekod michalli 13. 8. 2014 07:37

:D a proč instaluješ ten bordel od Samsungu? oni nemají nějakou serverovou verzi instalace? to je ovladač pro tiskárnu který si založí na počítači webový server??? :D
Michal Zobec
Senior IT Consultant, ZOBEC Consulting
michalli
Junior
Uživatelský avatar

Odeslat příspěvekod bajlek 13. 8. 2014 14:06

takže jsem se unáhlil a ještě něco blokuje HTTP službu resp. když ji po startu zastavím, tak IIS jede normálně.

michalli - instaloval jsem sit.tiskarnu od Samsungu a ver nebo ne, tohle jsem netusil. nikde na internetu neni ani dokumentace, nebo specifikace jinak je to tiskarna Samsung M2825ND

vyzkousim az tam nebudou pripojeni klienti
bajlek
Junior
Uživatelský avatar

Odeslat příspěvekod Milanr1 13. 8. 2014 14:21

Instaluj vždy jen čistý ovladač tiskárny, žádný bor-del okolo.
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod bajlek 13. 8. 2014 14:37

instaloval jsem čistý ovladač - eco driver je součástí :-/ v životě bych tohle dobrovolně neinstaloval. nicméně jak jsem psal, problém je ještě někde jinde...

//EDIT 13.8.2014 22:30
takže když jsem použil
Kód: Vybrat vše
sc stop http
sc config http start= disabled

a poté nastartoval IIS tak web jede OK a podařilo se mi i připojit klienta do domény pomocí connectoru. ale netusim jak vse rozbehat aby to fungovalo automaticky, protože jakmile nastavim sc config http start= auto tak skoncim tam kde jsem byl
bajlek
Junior
Uživatelský avatar


  • Podobná témata
    Odpovědi
    Zobrazení
    Autor

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 1 návštěvník