Identifikace vadné komponenty

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod Nargon 8. 11. 2015 08:06

Ahoj, tento týden jsem zjistil problém s počítačem. Jsem si celkem jistý, že je to HW porucha. Potřeboval bych pomoci s identifikací toho co problém způsobuje. Doufám že mi potvrdíte nebo vyvrátíte to co si myslím.

První jsem se všiml toho, že při přehrávání některých videí se po cca 10s přehrávání rozsype obraz a musím PC natvrdo restartovat tlačítkem na bedně. Nedělá to každé video, z toho co jsem vyzkoušel to dělají jen některé převážně ty s rozlišením 720p a vyšším. Pro představu rozsypaného obrazu zde je vyfocený monitor: http://i.imgur.com/DTo1XZe.jpg Ovšem když najdu soubor co to dělá tak mám 100% úspěšnost při znovu navození problému. Zapnu video a za 10s se porucha ukáže. Není to problém souboru, stejný soubor mi na jiném stroji jde přehrát v pohodě. Párkrát se místo rozsypání obrazu zobrazil BSOD s kódem 0x00000F4.
Další problém jsem zaregistroval následující den po rozsypání obrazu. Po delší době vypnutí PC (např přes noc) tak při zapnutí PC nedetekoval SSD se systémem (nebyl v biosu vidět), ale klasický HDD byl detekován normálně. Když PC asi po minutě restartuji tak je již korektně detekován i SSD a bez problému naběhne systém.

Pro úplnost uvedu i starší poruchy (vyskytují se již dlouhou dobu, asi rok), které s tím mohou mít souvislost:
Přibližně 1x za měsíc zpozoruji jakési probliknutí obrazu. Většinou když jen koukám na internet, tak to vypadá jakoby jeden snímek obrazu zmizel a místo něj se zobrazil bílý snímek. Vlastně to jen postřehnu, protože se všimnu toho že obraz se dobu cca 1/60s rozzáří bílou barvou. Ovšem protože se to vyskytovalo tak sporadicky tak jsem to neřešil.
Další starší závada je nefunkčnost režimu spánku (Suspend to RAM). Už to bude asi tak rok. Dříve mi režim spánku fungoval výborně, ale pak najednou z ničeho nic se pc již neprobudil. Asi tak 1s po probuzení se PC restartuje a začne nabíhat jako by nebyl uspaný, ale zcela vypnutý. Vyřešil jsem to tím že jsem místo spánku začal používat hibernaci (Suspend to HDD) a vše zase fungovalo. Start z hibernace na SSD je taky dost rychlý.

Kompletní sestava:
CPU: Intel Core i5-3570K (přetaktovaný na 4.2GHz)
Chladič: GELID Solution Tranquillo - revize 2
MB: ASUS P8Z77-M PRO - Intel Z77
RAM: Corsair Vengeance Low Profile Black 16GB (4x4GB) DDR3 1600
GK: Sapphire HD 7950 Vapor-X OC with Boost 3GB GDDR5
SSD: OCZ Vertex 4 - 128GB
HDD: Seagate Barracuda - 3TB
Zdroj: Enermax Liberty 500W (ELT500AWT) - link možná nesedí, určitě nemám ten pozdější "Liberty ECO" a tohle byl jediný co jsem našel.

Většina komponent byla zakoupena v říjnu roku 2012, takže teď jim jsou 3 roky a 1 měsíc. Až na zdroj, ten už prošel několika sestavami, ten jsem kupoval asi někdy v roce 2007, když mi odešel předchozí zdroj. A tento Enermax tehdy vyhrál řadu cen jako nejlepší zdroj, ale už mu přeci jen bude 8 let.

Ze začátku jsem si myslel že mi odešla grafika. Tak jsem zkusil spustit náročný 3D test (Furmark) a při zapnutí testu furmarku se PC okamžitě restartoval, nezahlédl jsem ani chloupek z testu. Když jsem pak měl problém i s nenalezeným ssd po startu tak mi nebylo jasné jak by grafika mohla ovlivnit detekci ssd. Tak jsem se spíš zaměřil na problém ve zdroji. Ovšem když jsem zkusil otestovat zátěž na CPU, tak byl PC stabilní, funkční a bez chybných výpočtů. Testoval jsem to pomocí Intel Burn Test. Je mi zvláštní že zvýšení zátěže o cca 55W nezpůsobilo žádný problém, protože těch 55W je rozhodně více než o kolik stoupne zátěž zdroje při přehrávání videa. Až jsem si pak všiml že hodnoty napětí co deska naměřila jsou dost nízké. viz screeny Idle a Load u +12V to při zátěži naměřilo jen 11.328V což je pod povoleným 5% limitem pro 12V větev (min by mělo být 11.4V). Žádná sláva to není ani u +5V větve, kde min limit je 4.75V a já tam mám 4.76V, což je sice v limitu ale dost na hraně.

Bohužel jiný zdroj tu nemám (teda mám tu nějaký 350W ale ten by na tu sestavu asi nestačil). Můžu leda tak vyzkoušet jinou grafiku nebo jet na integrovanou grafiku, ale pokud je problém ve zdroji tak mi ani jeden test nic neřekne, protože v každém případě bude zátěž zdroje nižší.

Tak co si myslíte vy? Také vidíte problém ve zdroji nebo si spíš myslíte něco jiného?
Díky za potvrzení nebo i vyvrácení toho kde si myslíte že problém je a nebo kde si myslíte že asi není.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor

Odeslat příspěvekod Milanr1 8. 11. 2015 08:30

Popisuješ (velmi podrobně) umírající VGA.
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod oooooooooo 8. 11. 2015 08:34

Jinak dobrej for - na rozdrbanym stroji at uz z jakyhokoliv duvodu provozovat taktle kompomenty - zajimave,asi nějaky nový hit...
http://seven7.blog.zive.cz/
Spuštění Windows předchází pád.
oooooooooo
Pokročilý
Uživatelský avatar

Odeslat příspěvekod Nargon 8. 11. 2015 09:29

Umírající VGA mě taky napadla, hned jak se mi rozsypal obraz. Jen je mi zvláštní že ve stejné době se objevil další problém s detekcí ssd. Přitom se nedělo nic zvláštního, mám na mysli např bouřku, která by něco mohla poškodit nebo výpadek proudu. A že by zčista jasna najednou odešlo více věcí je zvláštní. A pár dnů před problémy jsem měl jistě puštěnou nějakou hru a nevšiml jsem se žádných problémů. Jako například artefakty v obraze nebo problémy se stabilitou. Určitě tehdy fungovali i ty stejná videa, které dnes způsobí rozsypání obrazu. Vše běželo zcela bez problémů.
Jen dodám že mnou popisované probliknutí obrazu může být způsobené i monitorem, který asi taky není ve 100%ní kondici protože tam už před několika lety odešel USB hub. Jakmile ho připojím do PC tak pc nenabootuje a zasekne se na detekci USB zařízení. Jakmile monitor odpojím tak vše funguje.

Je mi divné že by odešlo více věcí najednou, nebo jak může odcházející grafika zapříčinit problém s detekcí disku v biosu. Proto jsem spíš hledal nějakou společnou komponentu, která způsobuje problém na obou stranách. Právě proto mě napadl spíše ten zdroj.

Jo OC na rozdrbaným stroji je nový hit. Nepřikládám tomu váhu protože jsem jen zvednul násobič, takty fsb, a napětí jsem nechal na defaultu bez změn. Ovšem vyzkouším OC zrušit, sice si nemyslím že to pomůže ale za zkoušku nic nedám.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor

Odeslat příspěvekod The Shitman 8. 11. 2015 09:30

Grafiku ven a zkoušej chvíli fungovat na integrované VGA.
The Shitman
Ex-moderátor
Uživatelský avatar

Odeslat příspěvekod Nargon 8. 11. 2015 09:49

Jdu si pohrát s odpojenou grafikou.

-- 8. 11. 2015 12:11 --

Grafika je venku. Na integrovanou intel to jede spolehlivě bez restartů a bez rozpadu obrazu.

Ale když jsem po vyndání grafiky zapínal PC tak jsem měl problém. Při vyndavání grafiky jsem zdroj samozřejmě vypl a odpojil kabel. Ovšem pak po opětovném připojení kabelu a zapnutí zdroje PC nereagoval na stisk tlačítka napájení. Zkoušel jsem to několikrát a nezapnul se. Zdroj jsem znovu odpojil/připojil a znovu jsem to zkoušel zapnout a zase nic. Tak ještě jednou jsem zdroj odpojil/připojil a pak už se tlačítkem zapnul. Podle indikační ledky na desce tam proud šel, ale zapnout se to nechtělo.
Grafikou to není, ta tou dobou ležela vedle. Takže buď ten zdroj a nebo odchází deska.

Teď když mi to naběhlo a zkouším zátěž, tak mi to opět ukazuje nižší napětí. V IDLE mi deska měří 11.424V na +12V větvi a při zátěži jen 11.232V, na +5V větvi mi deska při zátěži měří jen 4.720V což je už také pod 5% limitem pro ATX zdroje. Když už to mám rozebrané tak jsem si vzal i voltmetr a přeměřil jsem si +12V větev co jsem vytáhl z grafiky. v IDLE jsem naměřil 11.36V a při zátěži jen 11.18V.

Takže mám stále větší a větší podezření na zdroj, který už nedodává to co má a to pak vyvolává problémy když se grafika rozjede na plný takt.
Před tím jsem ještě vysledoval, že když pustím ty problematické filmy (kde se rozsype obraz), tak se grafika rozjede z klidových 300/1200 MHz (jádro/paměti) na plných 850/5000 MHz. Stejně jako když spouštím furmark.

Vidím to tedy asi na ten nový zdroj. Pak se uvidí zda problémy budou přetrvávat nebo zmizí.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor

Odeslat příspěvekod Nargon 10. 11. 2015 09:27

Koupil jsem nový zdroj a dal jsem ho tam. Rázem problémy ustaly. Dal jsem tam i tu vyndanou grafiku a taky funguje.

Po stisku tlačítka pro zapnutí se PC zapne. Opět jsem nastavil předchozí OC. Memtest jsem nechal pár hodin puštěný nenalezl žádnou chybu (kompletní test proběhl 2x). Ve win jsem zkusil zátěž přes Intel Burn Test a jede to krásně a stabilně. Furmark taky funguje, k žádným restartům už nedochází. Jen teď při testu jsem se všiml nižšího výkonu grafiky.
Ze začátku mi furmark ukazuje asi 86 fps, ale po nějakých 30s teplota grafiky vyleze na 51 stupňů a dojde k poklesu fps na 57. A i po několika minutách se teplota grafiky stále drží na 51 stupních a fps taky někde kolem 57. Tohle vypadá že grafiku začne omezovat nějaký tepelný limit, ale asi to bude jen nějaká drobnost v nastavení. Neměl jsem zatím moc času tak jsem se v tom do detailu nešťoural. Určitě ale vím že v době kdy jsem grafiku testoval naposledy (tj v době kdy jsem jí koupil, což je pár let) se takhle nechovala a teplota se dostávala až někam na 70 stupňů a pokles fps tam nebyl. Snad se k tomu večer dostanu.
Dokonce funguje i to probouzení z režimu spánku, které přestalo fungovat před dávnou dobou.

Na závěr ještě napíšu, že jsem vždy věděl že pořádný zdroj je důležitý základ PC, ale ani ve snu by mě nenapadlo jaké problémy mohou být způsobeny zdrojem.

-- 10. 11. 2015 22:17 --

Poslední info:
Grafiku stačilo v ovladačích nastavit a povolit jí vyšší tepelné ztráty. Teď už jede stabilně na 850MHz při cca 65 stupních. Není to jako s tím propadem FPS co jsem popisoval. To se grafika přepínala jen na 500MHz a pak zase zpět na 850 a zase na 500...
Cpu taky drží. Doufám že to takhle vydrží a nic už neodejde.

Děkuji všem co mi pomáhali.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor


  • Podobná témata
    Odpovědi
    Zobrazení
    Autor

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků