QEMU na RPi3 - nejde zvuk

Linux, Unix, BSD systémy, distribuce, open source

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod kubik.g 25. 3. 2017 17:26

Zdravím, s pomocí informací nasbíraných na internetu se mi podařilo na Raspberry Pi 3 rozjet pomocí QEMU Windows NT 4.0, funguje z toho přístup na internet, ovladač na grafiku to zdá se nainstalovalo automaticky, co mi ovšem nefunguje je zvuk. Systém spouštím pomocí tohoto příkazu
Kód: Vybrat vše
sudo qemu-system-i386 -cpu pentium -m 64 -hda NT4.disk -cdrom winnt.iso -boot d -boot menu=on -net nic,model=pcnet -net user -soundhw sb16
a po potvrzení se mi vypíše tohle
Kód: Vybrat vše
pulseaudio: pa_context_connect() failed
pulseaudio: Reason: Connection refused
pulseaudio: Failed to initialize PA contextaudio: Could not init `pa' audio driver
pro jistotu přikládám screenshot. Zvuk pak ve Windows samozřejmě nefunguje. Hledal jsem tenhle problém na netu, ale spousta návodů je obráceně, tedy jak pomocí QEMU emulovat Raspbian na Windows, já mám opačný případ. Nevíte někdo jak na to? V linuxu jsem začátečník, ale podle návodu nějakou tu práci s terminálem zvládám. Není to životně důležitý, hraju si s tím jen pro zábavu O:-) .
Přílohy
2017-03-25-161709_1280x1024_scrot.png
kubik.g
Junior

Odeslat příspěvekod soban 25. 3. 2017 20:55

A máš povolen audiovýstup ? TJ z linuxu to hraje?

https://www.raspberrypi.org/documentati ... -config.md

Máš v /boot/config.txt položku dtparam=audio=on ?

Taky záleží zda se snažíš přehrávat zvuk přes HDMI nebo přes analogovou zvukovku vyvedenou na jack.

Jinak zvukovka ve vlastním čipu je akorát na pípání na přehrávání nějaké hudby absolutně nevhodná (vlastní skušenost) pořiď si externí zvukovku do USB.

AXAGON USB HQ audio mini adapter
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod kubik.g 25. 3. 2017 22:05

Audiovýstup mám nastavený na analog, zvuk v Raspbianu normálně hraje. Jinak kvalitu zvuku jsem už řešil, šumělo to a celkově to hrálo docela hrozně, pomohl mi však tento návod - https://www.raspberrypi.org/forums/view ... 9&t=136445 . Pak je zvuk z jacku OK a nic nešumí.

Ano, v /boot/config.txt je řádek dtparam=audio=on.
kubik.g
Junior

Odeslat příspěvekod soban 26. 3. 2017 12:59

Našel jsem toto:

https://www.reddit.com/r/linux_gaming/c ... t_connect/

Skus to:

This is a simple fix:
Copy your cookie from ~/.config/pulse/cookie to /root/.config/pulse/cookie
Add a line to /root/.config/pulse/client.conf (You may want to copy the global conf file from /etc/pulse/client.conf if it doesn't exist):
default-server = unix:/run/user/$ID/pulse/native
Remember $ID is the id of your user (or whichever user is running the pulseaudio daemon that you want to share). If you only have one user $ID is probably 1000.
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý


  • Podobná témata
    Odpovědi
    Zobrazení
    Autor

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 2 návštevníků