MikroTik- ping s přeposláním na email

Routery, AP, switche, huby, ethernet

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod rakov 10. 3. 2017 10:23

Ahojte. Na MikroTiku jsem si dal sctript na ping na určitou adresu a v případě výpadku mi zašle email.
Ale to posíla stále v intervalech co mam nastavene v Scheduler .

:global server "77.75.76.48"
:global from "pepaxxx@seznam.cz"
:global to "pepaxxxx@seznam.cz"
:if ([/ping 192.168.1.10 count=5] = 0) \
do {
/tool e-mail send from=$from server=$server subject="VYPADEK AP1 $[/system clock get date] $[/system clock get time]" to=$to
}

Mám dotaz, jak to udělat aby to poslalo jen jeden email jen při výpadku a potom po celou dobu výpadku už ne.
Popřípadě to při naběhnutí zařízení na které pingam poslalo zase jen jeden email ze "AP1 FUNGUJE"?

Diky
rakov
Kolemjdoucí

Odeslat příspěvekod vladimir 10. 3. 2017 10:52

Možné řešení: nadefinuješ nějakou globální proměnnou (přepínač), která bude
- v případě úspěšného pingu nastavena na hodnotu přepínač=0
- v případě neúspěšného pingu a přepínač=nula se odešle mail a proměnná se nastaví přepínač=1
- v případě neúspěšného pingu a přepínač=jedna se nebude dít nic.

Musí to být globální proměnná (:global), která zůstane v operační paměti i po ukončení skriptu a bude k dispozici i ostatním skriptům nebo dalšímu volání stejného skriptu.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Nargon 10. 3. 2017 17:09

Případně druhá varianta je to co jsem ti psal už včera. Tj použít tool Netwatch, který ty servery monitoruje sám a nadefinované skripty spouští pouze při změně stavu. Tj z Down->Up a nebo z Up->Down, ale když se stav nemění tak nic nedělá.
Viz to co jsem ti psal, úplně dole na stránce: viewtopic.php?f=960&t=1260936&start=0
Jediné co musíš, tak do těch UP a DOWN skriptů zadat tohle odeslání emailu co jsi sem postnul.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor

Odeslat příspěvekod rakov 14. 3. 2017 12:07

Tak nakonec jsem to udělal s pomocí Netwatch.
Kde jsem zadal:
Host: X.X.X.X (IP adresa krerou chci kontrolovat)

interval: 00:02:00

On Up: /tool e-mail send from=xxx@seznam.cz server=77.75.76.48 to=xxx@seznam.cz subject="INTERNET-funguje $[/system clock get date] $[/system clock get time]"

On Down: /tool e-mail send from=xxx@seznam.cz server=77.75.76.48 to=xxx@seznam.cz subject="INTERNET-nefunguje $[/system clock get date] $[/system clock get time]"

Takže v případě vypadnutí AP, site atd přijde email oa vypadku a potom jak to zase naskočí, tak přijde email, že už zase vše funguje :-)


Díky všem za rady
rakov
Kolemjdoucí


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 2 návštevníků