Přidělování písmene diskům

Diskuze výhradně o operačním systému Windows 7

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod neo2 14. 9. 2012 19:40

Ahoj,

poslední dobou mám problém s připojováním externích HDD v rámečcích. Po připojení se detekuje ovladač, ale nepřidělí se mu písmenko. Když mu písmenko přidělím ručně, disk odpojím a připojím jiný disk tak se děje zase to samé, musím mu ručně přidělit písmenko. Přiděloval jsem jim stejné.

De mi ale o to, že toto jsem dříve nemusel nikdy dělat, když jsem prostě připojil disk (dostal např. písmeno H), pak jsem ho odpojil a připojil jiny tak zase dostal H. No teď vše musím dělat manuálně, nevíte kde by mohla být chyba? Dělá mi to jen krátkou dobu, nepamatuju se že bych dělal nějaké zásahy do správy disků.

Mám W7 32bit, legální, vše aktuální a jede na NB Dell E6410.


Dík za rady
neo2
Junior

Odeslat příspěvekod Milanr1 14. 9. 2012 20:47

Odpověděl sis sám, kde jsi spáchal chybu:
neo2 píše:Přiděloval jsem jim stejné.

A ještě k tomu pravděpodobně používáš pro stejné zařízení různé porty.
Co s tím?
1) Chovej se k OS korektně.
2) Resetuj zmatlaný USB řadič standardním postupem.
3) Chovej se k OS korektně.
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod spravait.net 14. 9. 2012 22:05

No zkusil bych:
1. odebrat radič USB, jak psal kolega (viz příspěvek výše)
2 zkusil bych jiného uživate pod Win (malá šance, ale občas překvapí)
3. zkus přímo příkazovou aplikaci Diskpart.exe (command line spráce disků), dočteš se tam víc a jako nouzovka lze udělat bat dávku, než to budeš chtít reinstalovat
4 reinstalace OS
spravait.net
Kolemjdoucí

Odeslat příspěvekod MiliNess 14. 9. 2012 23:25

Mohl bys vyexportovat a upnout klíč registru HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices ?
Hardwarová nezávislost znamená, že to neběží na žádném počítači.
MiliNess
Pokročilý

Odeslat příspěvekod neo2 15. 9. 2012 00:30

přikládám export registru.

Děkuji za rady, zkusím to prozkoušet jak píšete.



(toto forum nepodporuje snad žádné přípony, takže to dávám na uložto...)

http://ulozto.cz/xEmyPEX/mounted-rar


edit:
tak řadič odinstalovaný, pak znova nahozený - tady cesta nevede
neo2
Junior

Odeslat příspěvekod Milanr1 15. 9. 2012 03:48

Přílohy se ve fóru nevedou. Krátký text jsi mohl umístit přímo do zprávy, delší např. do code.
A pokud přílohy, tak ne do warezu, ale do solidního úložiště, např.
http://leteckaposta.cz/
Takže MiliNesse jsi nepotěšil! :-)

Možnosti:
A/ Zakázaná služba ShellHWDetection
Některé bezpečnostní aplikace zakazují potenciálně nebezpečné služby automaticky.
Co s tím?
Ověř:
cmd
sc query ShellHWDetection
Je zakázaná?
Spusť a povol:
admin konzole cmd
sc start ShellHWDetection
sc config ShellHWDetection start= auto
Ověř úspěšnost:
sc query ShellHWDetection
#pokud nejsi pánem nad cmd, můžeš příkazy prostě kopírovat.

B/ Zakázaný automount.
spravait.net píše:zkus přímo příkazovou aplikaci Diskpart.exe

1) Vyčisti registry od zmatků, které jsi tam spáchal:
admin konzole cmd
diskpart
automount scrub
Příkaz vyčistí klíč
MiliNess píše:HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

od nesmyslů.
2) Povol automount:
automount enable
3) Ověř úspěšnost své akce:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MountMgr\NoAutoMount
by měl mít hodnotu = 0.

Btw:
Brutální akce
spravait.net píše: reinstalace OS

= ajťáka nehodné! ;-)
V krajním případě poslouží obnova zdravého stavu OS ze zálohy.
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod spravait.net 15. 9. 2012 06:22

Milanr1 píše:= ajťáka nehodné! ;-)
V krajním případě poslouží obnova zdravého stavu OS ze zálohy.


:pozor no tvůj popis akce je pro BFU možná složitější než reinstalace OS :), nicméně pokud to tvůj popis pořešil, dávám palec nahoru :tleskani
mnohdy je rychlejší a vzhledem k OS i efektivnější a levnější instalace čistého OS, víš jak to většina lidí zaprasí do 2 týdnů od čisté instalace? hry, 100 různých programů na nic apod...
navíc předpokládáš zálohu OS, většina BFU neví co je norton ghost nebo true image a na co to je.
spravait.net
Kolemjdoucí

Odeslat příspěvekod neo2 15. 9. 2012 09:30

to Milanr1:

díky moc, už jsem to na základě tvých rad opravil.
Zafungovalo až to pročištění a spuštění automount, asi se při nečem vypnul.

Ještě jednou díky
neo2
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků