instalacia win 10 a generovanie odpovedi

Diskuze výhradně o operačním systému Windows 10

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod janyX 21. 11. 2019 16:50

Chcem otestovat instalaciu OS win 10 bez dotyku.
Existujuci PXE server nabootuje ..... a spusti setup.exe. Tu system zacina klast otazky aky jazyk ma pouzit, vyber klavesnice atd .
Hladal som ako sautomatizovat instalaciu a nasiel som nasledovne:

1) pouzit WADK s nastrojom WSIM
2) online generator

Nejaky navod na WSIM som nasiel, ale po vytvoreni autounatted.xml a umiestneni subora do korenoveho adresara sa nic nedialo (resp. som musel odpovedat na otazky klasicky mysou/klavesnicou).
Tak isto nefungoval ani spominany generator. Nema niekto skusenosti ako vytvorit bezdotykovu instalaciu Win 10 ?
janyX
Junior

Odeslat příspěvekod Milanr1 21. 11. 2019 17:44

Chyba je u Tebe:
janyX píše: Autounatted.xml

Správný název souboru:
autounattend.xml
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod janyX 21. 11. 2019 18:53

Ach Boze, uplne by mi stacilo keby som vedel citat pisnemka vratane "n"
Vdaka,
trapil som sa s tym par dni :-)
Teraz sa zacne autoinstalacia vykonavat ale po nakopirovani suborov na disk a restarte sa vypise, ze nieco v subore nie je v poriadku a subor neodpoveda na otazky, takze este to budem musiet doriesit.
Ak by ma niekto mohol nakopnut
Kód: Vybrat vše
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>sk-SK</UILanguage>
            </SetupUILanguage>
            <InputLocale>sk-SK</InputLocale>
            <SystemLocale>sk-SK</SystemLocale>
            <UILanguage>sk-SK</UILanguage>
            <UserLocale>sk-SK</UserLocale>
        </component>
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <DiskConfiguration>
                <Disk wcm:action="add">
                    <CreatePartitions>
                        <CreatePartition wcm:action="add">
                            <Order>1</Order>
                            <Size>500</Size>
                            <Type>Primary</Type>
                        </CreatePartition>
                        <CreatePartition wcm:action="add">
                            <Extend>true</Extend>
                            <Order>2</Order>
                            <Type>Primary</Type>
                        </CreatePartition>
                    </CreatePartitions>
                    <ModifyPartitions>
                        <ModifyPartition wcm:action="add">
                            <Active>true</Active>
                            <Format>NTFS</Format>
                            <Label>system</Label>
                            <Order>1</Order>
                            <PartitionID>1</PartitionID>
                        </ModifyPartition>
                        <ModifyPartition wcm:action="add">
                            <Format>NTFS</Format>
                            <Label>windows</Label>
                            <Letter>C</Letter>
                            <Order>2</Order>
                            <PartitionID>2</PartitionID>
                        </ModifyPartition>
                    </ModifyPartitions>
                    <DiskID>0</DiskID>
                    <WillWipeDisk>true</WillWipeDisk>
                </Disk>
                <WillShowUI>OnError</WillShowUI>
            </DiskConfiguration>
            <ImageInstall>
                <OSImage>
                    <InstallTo>
                        <DiskID>0</DiskID>
                        <PartitionID>2</PartitionID>
                    </InstallTo>
                </OSImage>
            </ImageInstall>
            <UserData>
                <ProductKey>
                    <Key>W269N-WFGWX-YVC9B-4J6C9-T83GX</Key>
                </ProductKey>
                <AcceptEula>true</AcceptEula>
                <Organization>WC</Organization>
            </UserData>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <OEMInformation>
                <Manufacturer>Sony</Manufacturer>
                <Model>Vaio</Model>
            </OEMInformation>
            <ComputerName>home-pc</ComputerName>
            <CopyProfile>true</CopyProfile>
            <RegisteredOrganization>Windows Central</RegisteredOrganization>
            <RegisteredOwner>WC</RegisteredOwner>
            <TimeZone></TimeZone>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>sk-SK</InputLocale>
            <SystemLocale>sk-SK</SystemLocale>
            <UILanguage>sk-SK</UILanguage>
            <UserLocale>sk-SK</UserLocale>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                <ProtectYourPC>1</ProtectYourPC>
            </OOBE>
            <UserAccounts>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Password>
                            <Value>MwB4AGoAYQBuAHkAeCC3AFAAYQBzAHMAdwBvAHIAZAA=</Value>
                            <PlainText>false</PlainText>
                        </Password>
                        <Description>local account</Description>
                        <DisplayName>admin</DisplayName>
                        <Group>Administrator</Group>
                        <Name>janyX</Name>
                    </LocalAccount>
                </LocalAccounts>
            </UserAccounts>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="wim:c:/win10/sources/install.wim#Windows 10 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
janyX
Junior

Odeslat příspěvekod milsimr 21. 11. 2019 19:47

Udělej spíš postup opačný. Vše nainstaluj ručně a pak si vytvoř image systémového disku. Pokud ho budeš chtít klonovat na vícero stanic, tak si skrze WSIM vytvoř odpovídací soubor, který použiješ s nástrojem sysprep.

S pomocí PXE serveru pak akorát rozklonuješ ....
Administrátor fóra Živě.cz.
milsimr
Administrátor
Uživatelský avatar

Odeslat příspěvekod janyX 21. 11. 2019 21:43

OK, skusim to aj takto

BTW uz mi to funguje korektne aj s vygenerovanym suborm z www.windowsafg.com/
janyX
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků