Wi-fi (shared key)

Linux, Unix, BSD systémy, distribuce, open source

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod Ťuhýk 7. 11. 2007 16:40

Ahoj mám problém s připojením k domáci wi-fi síti. Mám tu AP od Alfa network, nastavení DHCP a hexadecimal WEP shared key, na který se připojují dva ntb. Ve Windows i v Kubuntu (7.10) si to klikátkem není problém nastavit (v Kubuntu pomocí pomocí KNetwork Manageru). Narazil jsem ale na problém v distru Sabayon, které takové klikátko nemá (nebo teda má, ale v live cd verzi píše, že není aktivní).

Postupuji následovně pomocí příkazů

iwconfig eth1 essid <nazev>
iwconfig eth1 key <cislo>
dhclient

v tomto momentu notebook AP vidí, ping funguje a na jeho IP adresu se v browseru dostanu, ale nepustí mě to ven na internet. Ani ping nefunguje

Zkoušel jsem porovnat výpis iwconfig i iwlist eth1 key v obou distrech a všechno vypadá stejně. V čem může být problém? Je to ve špatném nastavení WEP klíče?
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 7. 11. 2007 20:00

Pokud si pingneš AP a dostaneš se na jeho administraci, není problém ve WEP klíči.


Zkus pingnout nebo do prohlížeče napsat třeba 77.75.76.3 (seznam.cz). Pokud to bude fungovat, chyba je s největší pravděpodobností v nastavení DNS serveru.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Ťuhýk 7. 11. 2007 20:44

Tak ted jsem to zkoušel, 77.75.76.3 opravdu pingnu... takže můžes mi poradit, jak ten DNS správně nastavit?
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar

Odeslat příspěvekod AndrewJ 7. 11. 2007 21:34

v kubuntu se soubor s DNS jmenuje resolv.conf a nachází se v adresáři /etc/

tak sem zkus hodit, co v něm máš napsáno.
AndrewJ
VIP uživatel
Uživatelský avatar

Odeslat příspěvekod Ťuhýk 7. 11. 2007 21:39

V kubuntu je tohle (takhle by to tedy asi mělo být správně):
Kód: Vybrat vše
# generated by NetworkManager, do not edit!

search local


nameserver 192.168.240.1


takze takhle mam editovat i prislusny soubor v Sabayonu?
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar

Odeslat příspěvekod AndrewJ 7. 11. 2007 21:43

nevím, jestli je to v sabayonu stejné, no nicméně to asi můžeš zkusit..

edit: bez záruky! vařím z vody!
AndrewJ
VIP uživatel
Uživatelský avatar

Odeslat příspěvekod running-free 7. 11. 2007 22:10

/etc/resolv.conf by měl být standardní všude
Unix - systém který vám dá dost provazů na to, abyste se sami oběsili.
running-free
Junior

Odeslat příspěvekod Ťuhýk 7. 11. 2007 22:15

Je i v Sabayonu, a opravdu to tam bylo jinak (špatně). Ale když jsem to editoval a uložil, tak se nic nezměnilo a stále to nefunguje...
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 7. 11. 2007 22:49

[quote="Ťuhýk"tAle když jsem to editoval a uložil, tak se nic nezměnilo a stále to nefunguje...e/quote]
A restartoval jsi počítač?
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Ťuhýk 7. 11. 2007 22:53

Nerestartoval. V prvním příspěvku jsem psal, že tohle zkouším na live cd...
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar

Odeslat příspěvekod FreeBSD_Radikal 7. 11. 2007 23:11

Po uprave /etc/resolv.conf NENI potreba pocitac restartovat.
BSD is for people who love Unix, Linux is for people who hate Windows.
notebook: Archlinux -current říznutej LFS ;-)
desktop: umrel
router: FreeBSD RELENG_6_2
FreeBSD_Radikal
Junior
Uživatelský avatar

Odeslat příspěvekod Ťuhýk 7. 11. 2007 23:18

No ono je taky možný, že jsem to upravil špatně. Nebo není třeba po úpravě resolv.conf zadat ještě nějaký příkaz?
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 7. 11. 2007 23:18

Tyhle textové konfigurace obvykle fungují až po restartu.
Zkus restartovat síť:
Kód: Vybrat vše
service network restart

nebo

/etc/init.d/network restart

Jesli to funguje i v Sabayonu, netuším.

Edit: FreeBSD_Radikal tvrdí, že restart není nutný. O.K. - přiznávám, že netuším.

Edit2:
[quote="Ťuhýk"tNo ono je taky možný, že jsem to upravil špatně. n/quote]
na konec /etc/resolv.conf jsi měl přidat řádek

nameserver 192.168.240.1

nebo pokud tam obdobný řádek byl, tak v něm jenom přepsat IP-adresu. Jiné změny nedělat.
(Předpokládám, že 192.168.240.1 je adresa tvého routeru, který poskytuje DNS-služby. Jinak tam taky můžeš napsat přímo DNS tvého internetového providera.)
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod FreeBSD_Radikal 8. 11. 2007 01:05

Otestovano, po zakomentovani /etc/resolv.conf prestal hned jit firefox a po jeho odkomentovani opet hned sel/
BSD is for people who love Unix, Linux is for people who hate Windows.
notebook: Archlinux -current říznutej LFS ;-)
desktop: umrel
router: FreeBSD RELENG_6_2
FreeBSD_Radikal
Junior
Uživatelský avatar

Odeslat příspěvekod Ťuhýk 8. 11. 2007 01:29

Takže posun:

vladimir: ani jeden z těch příkazů nefungoval, po troše zkoušení jsem dospěl k tomuhle:

Kód: Vybrat vše
sabayonuser@sabayonx86-64 ~ $ sudo /etc/init.d/net.eth0 restart
* Caching service dependencies ...                                       [ ok ]
* Starting eth0
*     /etc/conf.d/wireless is deprecated
*     Please put all settings in /etc/conf.d/net
*     /etc/conf.d/wireless is deprecated
*     Please put all settings in /etc/conf.d/net
*   Configuring wireless network for eth0
*   WEP key is not set for "TVR.HN" - not connecting
*   Couldn't associate with any access points on eth0
*   Failed to configure wireless for eth0     


no takže se zítra podívam na ty soubory, ted na to nemám sílu
Všechno, co v životě opravdu potřebuju znát, jsem se naučil ze Star Treku
Ťuhýk
Junior
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků