problém se Skype

Linux, Unix, BSD systémy, distribuce, open source

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod celim 20. 2. 2010 15:28

nejde mi v Mandrivě Skype, prý mu chybí QT4(co to je?). Jak nejjednodušeji to vyřešit?Poradí mi někdo?
celim
Junior

Odeslat příspěvekod nfp1 20. 2. 2010 16:51

Soubory knihoven. Nainstaluj z repozitářů přesně to, o co si píše.
nfp1
Junior

Odeslat příspěvekod lurk3r 20. 2. 2010 20:00

Instaloval si z repozitářů nebo z balíčku? Tváří se to jako by si měl verzi pro KDE (Qt knihovny), ale používal jiný window manager (Gnome - GTK knihovny, ... nebo jiný). Skype nenajde Qt a takl nemůže vzkreslit okna -> nespustí se. Řešením je doinstalovat Qt knihovny nebo nainstalovat verzi pro GTK.
Moderátor diskuzního fóra Živě.cz

If there is no space left on the device, there must be some space right ...
Co říká bezpečnostní software chycenému červovi? "Jsi zatčen! A nezkoušej na mě žádný fork()y!"
lurk3r
VIP uživatel
Uživatelský avatar

Odeslat příspěvekod alazar 21. 2. 2010 22:43

Jak jsi nainstaloval Skype, stahoval jsi ho z oficialniho webu nebo pres instalaci software primo v Mandrive? Pokud jsi stahoval z webu, zkus mozna nainstalovat staticky slinkovanou verzi Skype (http://www.skype.com/go/getskype-linux-beta-static). Ta by mela sama obsahovat vsechny potrebne knihovny. Jinak Qt4 je velka knihovna, ktera (mimo jine) umi vykreslovat okna a prvky GUI.

[lurk3r] Nesmysly. Na window manageru nezalezi (pokud mam XMonad, budu poustet programy s GUI v Haskellu? :D), stejne tak neexistuji ruzne verze Skype (ani jineho bezneho softwaru) pro ruzne graficke knihovny. Naopak zavislosti automaticky resi balickovaci manazer (at instaluju z repa nebo z balicku).
V ramci kazdeho WM lze spustit program bezici na libovolne graficke knihovne, pokud je nainstalovana. WM a pouziti graficke knihovny spolu absolutne nesouvisi.
alazar
Junior

Odeslat příspěvekod lurk3r 22. 2. 2010 11:52

alazar: asi si mě spatně pochopil, jasný, že aplikace pro KDE, spustíš pod GNOME, ale bez Qt knihoven ne, to je to na co sem narážel ...
Moderátor diskuzního fóra Živě.cz

If there is no space left on the device, there must be some space right ...
Co říká bezpečnostní software chycenému červovi? "Jsi zatčen! A nezkoušej na mě žádný fork()y!"
lurk3r
VIP uživatel
Uživatelský avatar

Odeslat příspěvekod vpjvm 22. 2. 2010 13:54

Používám Mandrivu a KDE a při pokusu o instalaci staženého Skype jsem dostal tuto hlášku:
"Einige der ausgewählten Pakete können nicht installiert werden:
skype-2.1.0.81-suse111.i586 (wegen nicht erfüllter Abhängigkeit von qt[>=4.2])
Wollen Sie trotzdem fortfahren?"
V češtině by to mělo znamenat toto:
"Některé z vybraných balíčků nemohly být nainstalovány:
skype-2.1.0.81-suse111.i586 (kvůli nesplněné závislosti na qt[>=4.2])
Chcete přesto pokračovat?"

Jak to mám řešit?
vpjvm
Kolemjdoucí

Odeslat příspěvekod gambolputty 12. 3. 2010 19:52

Zkuste si vygooglit starší verzi Skype. Mně dobře funguje 2.0.0.72
Balíček se myslím jmenuje - skype-2.0.0.72-mdv.i586.rpm
Za výsledek neručím, ale já Skype takto bez problémů provozuji
[url=http://topstockcars.com/2007-dodge-caliber/]2007 dodge caliber[/url] [url=http://topstockcars.com/2009-dodge-circuit-ev/]2009 dodge circuit ev[/url]
gambolputty
Junior
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků