Aku distribuciu Linuxu pouzivate?

Linux, Unix, BSD systémy, distribuce, open source

Moderátor: Moderátoři Živě.cz

Aku distribuciu GNU/Linuxu pouzivate?
Ubuntu/Kubuntu 102 %  33%  [ 102 ]
Mandriva/Mandrake 41 %  13%  [ 41 ]
SUSE 61 %  19%  [ 61 ]
Fedora/RedHat 18 %  5%  [ 18 ]
Debian 23 %  7%  [ 23 ]
Gentoo 33 %  10%  [ 33 ]
Slackware 16 %  5%  [ 16 ]
Aurox 1 %  0%  [ 1 ]
PCLinuxOS 7 %  2%  [ 7 ]
Arch 6 %  1%  [ 6 ]
Celkem hlasů : 308

Odeslat příspěvekod decried 2. 6. 2006 20:43

Gentoo je super ale vadili mi dlhotrvajuce kompilacie a optimalizacie tak som presiel na ubuntu. Ale nevylucujem moznost ze sa ku gentoo este vratim.
Make it idiot proof and someone will make a better idiot.
decried
VIP uživatel
Uživatelský avatar

Odeslat příspěvekod AraxoN 2. 6. 2006 21:09

decried píše:Gentoo je super ale vadili mi dlhotrvajuce kompilacie a optimalizacie tak som presiel na ubuntu. Ale nevylucujem moznost ze sa ku gentoo este vratim.

jj, ja to mám na notebooku a v jednom kuse mi to niečo kompiluje... Zatiaľ ma to baví, a hlavne testujem stabilitu (zatiaľ spokojnosť). Stále zvažujem, či Gentoo môžem bez obáv dať aj na server... Možno dnes budem vedieť viac - práve riešim konflikt medzi pam-login a shadow a medzi utempter a libutempter - ak to dopadne pádom, alebo nedostupnosťou systému, tak to bude asi koniec mojich plánov na Gentoo server. Nechám sa prekvapiť.
Podporujte baktérie - pre veľa ľudí je to jediná kultúra, ktorú majú.
AraxoN
Junior
Uživatelský avatar

Odeslat příspěvekod x22 2. 6. 2006 23:34

Tak to treba ten shadow instalovat (updatovat) okamzite po odstarneni pam-login, lebo medzitym nefunguje login, takze sa neda prihlasit (pokial nepouzivas graficke prihlasenie). Odporucam si shadow dopredu stiahnut pomocou emrege --fetchonly, keby nahodou padol net.
x22
Junior

Odeslat příspěvekod oooooooooo 2. 6. 2006 23:53

dta píše:MarrLiss: Díky moc. To v podstatě vyřešilo všechny moje požadavky. V kurl=http://www.kubuntu.de/index.php?option=com_content&task=view&id=18&Itemid=40]repozitáři kubuntu.ded/url] je přesně to co potřebuji. Nejnovější amaroK a Kaffeine. Nejnovější KDE a KOffice je zase na kubuntu.org. Nakonec to vypadá, že Kubuntu je distribuce s nejlepší podporou KDE.

durl=http://forum.zive.cz/viewtopic.php?p=247680&highlight=#247680]oooooooooo[/url]: Jestli myslíš repozitáře jako universe, tak z těch nic nepotřebuji. Mě šlo spíš o tu aktuálnost. A
oooooooooo
Pokročilý
Uživatelský avatar

Odeslat příspěvekod Corwin 3. 6. 2006 00:43

AraxoN píše:Stále zvažujem, či Gentoo môžem bez obáv dať aj na server... Možno dnes budem vedieť viac - práve riešim konflikt medzi pam-login a shadow a medzi utempter a libutempter - ak to dopadne pádom, alebo nedostupnosťou systému, tak to bude asi koniec mojich plánov na Gentoo server. Nechám sa prekvapiť.
Corwin
Junior

Odeslat příspěvekod AraxoN 3. 6. 2006 09:11

x22: vďaka za radu, poriešil som to bez toho, ale máš pravdu, že keby mi padol net, alebo vypadlo napájanie (resp. zdochla baterka), tak by som bol pekne v pr... :?
Pozrel som si predtým, že pam-login sa vlastne začlenil do novej verzie shadow, a podobne aj ten utempter, takže som ten starý balíček unmergol a ten novší následne updatol. Tú fičúru s fetchonly si musím ešte nacvičiť.

Corwin: to máš tak. Na server potrebujem niečo, čím si budem istý. S Gentoo sa hrajem zhruba 2 mesiace, a istotu v ňom nemám. Chystáme sa spustiť projekt, v ktorom bude dostupnosť a bezpečnosť servra kľúčová. Zatiaľ som sa celkom pekne sklamal v RPM-based distribúciách, a ani Debian ma nepotešil keď minule ohlásil, že končí s podporou Woody.
Operácia spomínaná v mojom včerajšom poste dopadla úspešne a bezproblémovo, takže Gentoo je stále v hre. Musím povedať, že sa mi páči.
Podporujte baktérie - pre veľa ľudí je to jediná kultúra, ktorú majú.
AraxoN
Junior
Uživatelský avatar

Odeslat příspěvekod Corwin 3. 6. 2006 11:04

AraxoN píše:x22: vďaka za radu, poriešil som to bez toho, ale máš pravdu, že keby mi padol net, alebo vypadlo napájanie (resp. zdochla baterka), tak by som bol pekne v pr... Confused
Pozrel som si predtým, že pam-login sa vlastne začlenil do novej verzie shadow, a podobne aj ten utempter, takže som ten starý balíček unmergol a ten novší následne updatol. Tú fičúru s fetchonly si musím ešte nacvičiť. s/quote]

Nebol by si nutne v *****, len by si sa neprihlasil. Zamerne pisem len, pretoze sa chcem spytat, ci by riesenie v podobe bootu z livecd a nasledneho fixu problemu (v chroote samozrejme) nepomohlo?

AraxoN píše:Na server potrebujem niečo, čím si budem istý. S Gentoo sa hrajem zhruba 2 mesiace, a istotu v ňom nemám. Chystáme sa spustiť projekt, v ktorom bude dostupnosť a bezpečnosť servra kľúčová. Zatiaľ som sa celkom pekne sklamal v RPM-based distribúciách, a ani Debian ma nepotešil keď minule ohlásil, že končí s podporou Woody.
Operácia spomínaná v mojom včerajšom poste dopadla úspešne a bezproblémovo, takže Gentoo je stále v hre. Musím povedať, že sa mi páči.h/quote]


Mno, ze sa ti paci, to je fajn, ale podla toho, co pises, by som v najblizsej dobe (ak si neurobis intenzivny trening), nad gentoo na serveri ani neuvazoval. Pretoze si si nim este neni isty. Debian - woody je na svete od 2002, a teraz v juni konci podpora, priznam sa, ze netusim, ze preco ta nepotesilo zrusenie, ked ti ide o novy server a tudiz tam asi das aj tak sarge, nie? Resp. co presne ti prekaza na sargovi? Ak by som ja osobne mal volit distro na server, co teraz vlastne aj riesim, kedze rusim freebsd a idem dat linux (objektivna pricina - podpora xenu, ktora sa bude pre freebsd teraz v ramci summer of code len dorabat..) a volbou bude bud debian alebo gentoo.. Inak sa priznam, forums.gentoo.org je nieco tak skvele, ze sam som tam xkrat cerpal informacie pri rieseni roznych problemov aj na mojich bsd strojoch.. drzim palce (skus ten intenzivny trening a hlavne na server nepchaj ~x86 balicky pri gentoo :)).
Corwin
Junior

Odeslat příspěvekod Zorg 3. 6. 2006 11:34

Gentoo na serveru mi běží rok k naprosté spokojenosti. Asi nejvíc se mi líbí způsob instalace SW (emerge je skvělý nástroj), absolutní kontrola nad systémem a samozřejmě forums.gentoo.org + gentoo-wiki.com :-)
~x86 balíčku se člověk semtam nevyhne, ale potom stačí jenom přidat řádek do /etc/portage/package.keywords - jednoduchost sama.
Zorg
Junior

Odeslat příspěvekod AraxoN 3. 6. 2006 13:06

Nemyslím, že by som na serveri potreboval niečo čo je masked ~x86. Na noťasi mám z masked vecí len ArgoUML, Eclipse (obe Java), a OpenTTD 0.4.7 (gamesa). Mám tam inak všetky veci, ktoré potrebujem aj na servri, a nebol problém - všetky sú stable v dostatočnej verzii.
Z liveCD by som to nabootoval, ale všetky liveCD mám v kancelárii, a so systémom, do ktorého sa nedá prihlásiť, si asi ťažko stiahnem a vypálim ďalšie.
A ak by sa mi to prihodilo na servri, tak to by bolo veľmi nemilé. Služby čo potrebujem by možno fungovali, ale lietať cez pol mesta do hostingového centra a tam to lokálne riešiť - to by som si pripadal ako správca Windows servra. :P
Woody ma nepotešil, lebo postarší server s Woodym nám už beží, a ak sa objaví nejaká nová zraniteľnosť, na ktorú nebude triviálne inštalovateľná záplata, tak nebudem kľudne spať. Viem, že by som mal priebežne migrovať a preinštalovávať, ale to chce čas a vysvetli vedeniu a klientom prečo robíš niečo o čo ťa nikto nežiadal, a nerobíš tie banality, ktoré sú podľa nich dôležité.
Podporujte baktérie - pre veľa ľudí je to jediná kultúra, ktorú majú.
AraxoN
Junior
Uživatelský avatar

Odeslat příspěvekod Corwin 3. 6. 2006 13:18

AraxoN píše:Nemyslím, že by som na serveri potreboval niečo čo je masked ~x86. Na noťasi mám z masked vecí len ArgoUML, Eclipse (obe Java), a OpenTTD 0.4.7 (gamesa). Mám tam inak všetky veci, ktoré potrebujem aj na servri, a nebol problém - všetky sú stable v dostatočnej verzii.o/quote]
Na server by som skutocne nesiel s ~x86. Sice moj nazor na to, ako gentoo team rozhoduje, kedy co ide do stable vetvy, je trosku kriticky, niekedy su fakt dost zabrzdeni kvoli banalite, ale v pripade servera niet o com diskutovat - stable :). Tam sa potom gentoo vie javit ako velmi dobra volba. (Transport Tycoon bola skvela vec! :))
AraxoN píše:Z liveCD by som to nabootoval, ale všetky liveCD mám v kancelárii, a so systémom, do ktorého sa nedá prihlásiť, si asi ťažko stiahnem a vypálim ďalšie.
A ak by sa mi to prihodilo na servri, tak to by bolo veľmi nemilé. Služby čo potrebujem by možno fungovali, ale lietať cez pol mesta do hostingového centra a tam to lokálne riešiť - to by som si pripadal ako správca Windows servra.s/quote]
Skus livecd nosit pri sebe (su aj creditcard formaty, spominam si na lnx bbc livecko). Ale inak suhlasim ohladne servera.. mozno skusit v hostingu zariadit niekoho ako "hands and eyes", ale za to sa bude platit neaky ten $$$.
AraxoN píše:Woody ma nepotešil, lebo postarší server s Woodym nám už beží, a ak sa objaví nejaká nová zraniteľnosť, na ktorú nebude triviálne inštalovateľná záplata, tak nebudem kľudne spať. Viem, že by som mal priebežne migrovať a preinštalovávať, ale to chce čas a vysvetli vedeniu a klientom prečo robíš niečo o čo ťa nikto nežiadal, a nerobíš tie banality, ktoré sú podľa nich dôležité.a/quote]

O dovod viac preco upgradovat. Samozrejme, ze to chce cas :), od toho mas rozne SLA a podobne, na ktorych by ste sa s klientami mohli dohodnut. V ramci toho viete mat urcity casovy fond pre planovane vypadky -> naplanujes downtime kvoli upgradu (vysvetlis klientom, ze ich stranky pobezia rychlejsie, a vobec, ze vsetko bude jagavejsie a lepsie :) ).. a upgradujes.. to je vsak uz vec procesov firmy a komunikacie s klientami a je mimo temu volby distra na server :).
Corwin
Junior

Odeslat příspěvekod Petr Tomeš 4. 6. 2006 15:30

dta píše:Omlouvám se za offtopic, ale měl bych otázku asi na Petra Tomeše, který Ubuntu dost často doporučuje.
Proč K/Ubuntu neobsahuje trochu novejší software? Myslím, že pro systém zaměřený na desktop by mohlo být uskutečnitelné alespoň aby v době vydání měl aktuální software. Např. můj oblíbený video přehrávač Kaffeine vyšel ve verzi 0.8.1 už na začátku dubna, ale v Ubuntu je verze ze září '05; hudební přehrávač amaroK vyšel před 14 dny v zbrusu nové verzi, ale v repozitářích je 1.3.9.
KDE 3.5.3 vyšlo před pár dny, Firefox 1.5.0.4 vyšel včera. Dapper-backports ještě neexistuje. Kdy se dá asi tak očekávat dostupnost těchto novinek v K/Ubuntu?d/quote]


K/Ubuntu je moderní distribuce s půlročním vývojovým cyklem. Oproti SUSE 10.1, které vyšlo 11.5.2006, obsahuje většinou novější aplikace i pracovní prostředí (např. KDE 3.5.2, SUSE: 3.5.1; GNOME 2.14.1 oproti SUSE: 2.12 apod.). Podobné rozdíly v aktuálnosti softwaru najdete i ve vztahu k jiným distribucím, např. Mandrivě.

Betaverze i konečné verze Amaroku 1.4, Koffive 1.5.1 KDE 3.5.2 nabídlo Kubuntu jako jedna z prvních distribucí vůbec:
http://kubuntu.org/

Firefox 1.5.0.4 (a podobně Thunderbird 1.5.0.4 a další aplikace) nejsou potřeba, jelikož všechny bezpečnostní a důležité stabilitostní aktualizace jsou dodávány v rámci aktualizace celého vydání distribuce:
http://changelogs.ubuntu.com/changelogs/pool/main/f/firefox/firefox_1.5.dfsg+1.5.0.3-0ubuntu3/changelog

Pro instalaci novějších verzí některých programů slouží neoficiální kanály a zdroje, nicméně riskujete stabilitu a funkčnost, přesně to je důvod, proč nebyly zařazeny např. do tzv. backportů.
Petr Tomeš
Junior
Uživatelský avatar

Odeslat příspěvekod Zorg 4. 6. 2006 17:28

V tom případě všem s pouze stable Gentoo balíčky gratuluji :-) Bohužel to není vždy tak jednoduché, například PHP5 (dokonce hard masked) a MySQL 4.1 (na to byl potřeba overlay) v době zhruba před rokem nebo třeba cyrus-sasl ve verzi, která podporovala crypt hesla atd. Všechny tyhle programy se po testování ukázaly jako perfektně stabilní, stačilo jenom počkat na stable balíček a potom jejich ~x86 zrušit.
Asterisk VoIP ústředna ve verzi 1.2, Postgres 8.1 nebo MySQL 5.0 jsou testing pořád. Pokud zůstanete jenom u stable balíčků, tak si tím někdy přiděláte mnohem víc problémů s pozdějším upgradem a s tím, že bude chybět požadovaná funkčnost. A kompilovat sám je ještě mnohem horší řešení.
Ale samozřejmě nikomu nic nevnucuji, jsou to jenom osobní postřehy :-)
Zorg
Junior

Odeslat příspěvekod AraxoN 4. 6. 2006 18:02

Zorg: ja som v tomto nenáročný. Zažil som časy, keď PHP4 bola žhavá novinka a nejaké MySQL 4 v nedohľadne. Dalo sa s tým žiť, a aj veľké projekty to zvládlo. Takže latest stable je pre mňa OK.
Podporujte baktérie - pre veľa ľudí je to jediná kultúra, ktorú majú.
AraxoN
Junior
Uživatelský avatar

Odeslat příspěvekod ycuzo 4. 6. 2006 18:31

notebook MDV2006 na pc MDK9.2
ycuzo
Junior

Odeslat příspěvekod Zorg 4. 6. 2006 19:34

Zažil jsem časy, kdy PHP4 ještě neexistovalo a session se dělaly přes PHPLIB. Ale bohužel je to často požadováno a odpověď "Není na to ještě stable balíček" nikoho nezajímá.
Ale to už se dostávám někam hodně offtopic. Prostě Gentoo je ok :-)
Zorg
Junior

Předchozí stránkaDalší stránka

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků