Stránka 1 z 1

Drag and drop v Ubuntu 5.04

Odeslat příspěvekNapsal: 8. 5. 2006 07:09
od d_Hemon
Dobrý den,
mám vytvořený skript, který potřebuji spouštět s několika parametry (soubory). Z konzole funguje OK, ale je to skript pro přítelkyni, aby vybrala obrázky stažené z foťáku a zmenšila je přetažením na ikonu toho skriptu. Ten skript pozná orientaci obrázku a zmenší ho na potřebné rozměry. Přítelkyně samozřejmě potřebuje, aby to fungovalo drag and drop, tedy vybrat obrázky z nautilusu, přetáhnout na ikonu skriptu a nechat skript pracovat.

Jenže skript se po přetažení neoznačí a obrázky se jen přesunou. Přitom u zástupců aplikací tento systém funguje. Je to vlastnost Ubuntu 5.04 nebo se to dá někde nastavit? Samozřejmě bych spíš stáhnul 5.10, ale mám pomalé připojení. Díky za rady

Odeslat příspěvekNapsal: 8. 5. 2006 08:18
od dta
Tohle je spíš záležitost grafického prostředí GNOME/Nautilus než distribuce jako takové. Napadá mě akorát - má ten skript spouštěcí atribut? Pokud ano, pak si myslím, že by se měl chovat stejně jako jakýkoliv program. Možná bug, netuším. Někdo, kdo má nejnovější GNOME, by to mohl vyzkoušet.

Odeslat příspěvekNapsal: 8. 5. 2006 08:23
od d_Hemon
Spouštěcí parametr to má pro všechny. Zkoušel jsem to u bratra, má 5.10 a tam to jelo ok.. Je mi to fakt divný..Dá se ze synapticu nebo apt-get ugradeovat prostředí gnome? (V linuxu začínám a zatím mám v tom trošku ice-hockey)

Odeslat příspěvekNapsal: 8. 5. 2006 08:59
od dta
Ano, určitě to jde. Ale nevím jak, protože sám Ubuntu nemám. Někdo jiný určitě poradí.

Odeslat příspěvekNapsal: 8. 5. 2006 09:02
od d_Hemon
Vyzkouším to nějak zpytlíkovat, díky moc.

Odeslat příspěvekNapsal: 8. 5. 2006 09:17
od oooooooooo
d_Hemon píše:Spouštěcí parametr to má pro všechny. Zkoušel jsem to u bratra, má 5.10 a tam to jelo ok.. Je mi to fakt divný..Dá se ze synapticu nebo apt-get ugradeovat prostředí gnome? (V linuxu začínám a zatím mám v tom trošku ice-hockey)o/quote]

sudo apt-get update
sudo apt-get dist-upgrade
No a mas aktualizovany distro
Pokud nechces komplet tak v synapticu vyber co chces-aktualizovat a je to on si chybejivci knihovny a zavislosti resi sam.

Odeslat příspěvekNapsal: 8. 5. 2006 09:30
od d_Hemon
Danke šén.. Musím opravit i sources.list (myslim replace hoary->breezy nebo dapper), nebo to najde bez toho?

Odeslat příspěvekNapsal: 8. 5. 2006 09:47
od oooooooooo
Upravit -staci prepsat ,velmi spravne misto breezy-to co budete pouzivat .Pokud chcete zustat na treba 5.1 i nadale nebo co mate tak nic neprepisovat dojde jen k ciste aktualizaci ale rada 5.04,5.10 bude zachovana.
Jinak na ubuntu.cz maji kluci pastly sources list pro dappera radej bych ho zkopcil a vlozil az pak dal update-muzete mit nakej prehistorickej kde uz vlastne plno veci je mrtvych.

Odeslat příspěvekNapsal: 8. 5. 2006 09:57
od d_Hemon
Tak už jsem v obraze..děkuju

Odeslat příspěvekNapsal: 11. 5. 2006 18:59
od Petr Tomeš
oooooooooo píše:Upravit -staci prepsat ,velmi spravne misto breezy-to co budete pouzivat .


Nemáte pravdu. Podporovány jsou pouze aktualizace na vydání následující po tom používaném. Jakékoliv další situace lze označit za experiment, který není podporován a nemusí správně fungovat...