nefunguje NTFS-3g

Linux, Unix, BSD systémy, distribuce, open source

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod mrajda 18. 11. 2006 18:21

Víte si někdo rady s podporou NTFS-3g?
Nainstaloval jsem to podle navodu http://wiki.linux-ntfs.org/doku.php?id=ntfs-3g

ale
ntfs-3g /dev/sda5 /mnt/windows
mi nejede :-( Disky se nezobrazi.. (hlasi to tyhle erorry:
fusermount: failed to access mountpoint /mnt/windows: No such file or directory
Failed to create FUSE mount point.
Retry to create FUSE mount point ...
fusermount: failed to access mountpoint /mnt/windows: No such file or directory
Failed to create FUSE mount point.
Unmounting /dev/sda5 ()
)

Nevíte někdo co s tím? Potřeboval bych ten disk nějak rozchodit. Jinak linux mam na starším IDE disku a WIN na části SDA..

Mam DANIX.

Thanks!
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod JIV 18. 11. 2006 18:51

failed to access mountpoint /mnt/windows: No such file or directory
a ty nevies po anglicky?
mas vytvoreny ten priecinok? alebo mountujes to pod rootom?
All living things must eat.
As I have said, all living things must eat.
Podpora X
JIV
Pokročilý
Uživatelský avatar

Odeslat příspěvekod mrajda 18. 11. 2006 18:52

No, tak trochu ano.. ale spiš jsem linuxový začátečník..
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod dta 18. 11. 2006 18:52

Kód: Vybrat vše
mkdir /mnt/windows
Když chceš v linuxu připojit nějaké zařízení do adresářové struktury, tak ten adresář musí existovat.
Naposledy upravil dta dne 18. 11. 2006 18:56, celkově upraveno 1
dta
Junior
Uživatelský avatar

Odeslat příspěvekod mrajda 18. 11. 2006 18:54

# ntfs-3g /dev/sda5 /mnt/windows
fusermount: mount failed: No such device
Failed to create FUSE mount point.
Retry to create FUSE mount point ...
fusermount: mount failed: No such device
Failed to create FUSE mount point.
Unmounting /dev/sda5 ()


po vytvoření adresáře, pokud jsi myslel toto
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod dta 18. 11. 2006 18:59

Ano, první problém je pryč, ale je tu druhý. Tentokrát tvrdí, že zařízení neexistuje. Jsi si jistý, že oddíl s Windows je sda5?
dta
Junior
Uživatelský avatar

Odeslat příspěvekod mrajda 18. 11. 2006 19:01

ano, je partition a disku SDA - kde je ještě sda6, ale tu až tak nepotřebuji.. dík za rady.
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod mrajda 18. 11. 2006 19:14

priecinok nemám - to je na co?
zkoušel jsem obojí.. mountovat to i pod ROOTem, ale bylo to na stejno
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod dta 18. 11. 2006 20:01

mrajda píše:priecinok nemám - to je na co??/quote]To je slovensky adresář. :)-quote="mrajda"]zkoušel jsem obojí.. mountovat to i pod ROOTem, ale bylo to na stejnon/quote]
Vždycky mountuj jako root. Zkus ten oddíl připojit pomocí ovladače v jádře:
Kód: Vybrat vše
mount -t ntfs /dev/sda5 /mnt/windows
dta
Junior
Uživatelský avatar

Odeslat příspěvekod mrajda 18. 11. 2006 20:17

kouknu na to, jen přebootuju..
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod mrajda 18. 11. 2006 21:36

díky, funguje :)
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Odeslat příspěvekod dta 19. 11. 2006 00:21

No, to je sice dobře, ale neřeší to problém s ntfs-3g. Ovladač v jádře je pouze pro čtení. Zajímalo mě akorát, jestli není něco špatně s tím zařízením když to nejde připojit. Danix jsem viděl naposled asi před 3 roky, takže ani moc nevím jak to tam funguje. Snad někoho něco napadne.
dta
Junior
Uživatelský avatar

Odeslat příspěvekod zero0x 19. 11. 2006 08:26

ten program sa pouziva inak ako mount.. neviem teda ja ked som dal ntfs-3g /mnt/windows tak mi to neslo, ale ked som dal ntfs-3g /dev/[zariadenie] tak to islo f poho.
zero0x
Junior

Odeslat příspěvekod dta 19. 11. 2006 10:33

zero0x: http://www.ntfs-3g.org/index.html#usage, i v manuálu se píše
Kód: Vybrat vše
ntfs-3g device mount_point [-o options]
a ani mi to nefunguje:
Kód: Vybrat vše
[root@meda ~]# ntfs-3g /dev/sda3
fuse: missing mountpoint
Retrying mount ...
fuse: missing mountpoint
Failed to mount NTFS
Unmounting /dev/sda3 ()
dta
Junior
Uživatelský avatar

Odeslat příspěvekod mrajda 19. 11. 2006 11:09

Hmmm, tak při novém nabootování je to zase odpojené..

ntfs-3g device mount_point [-o options]
a tohle teda taky nejede :-(

Ještě malý dotaz. Když to mountuju přes root a pak chci změnit práva pro normálního uživatele. jaký tam dám parametr aby se změnili práva v celém adresáři i podadresářích. chmod -D 777 /mnt/windows?
:: bramborák s česnekem ::
mrajda
Junior
Uživatelský avatar

Další stránka

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků