vim v solarise

Linux, Unix, BSD systémy, distribuce, open source

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod igo 29. 3. 2007 13:55

pekny den,
snazim sa nainstalovat novy vim na solaris a dosiel som k chybe

ld.so.1: vim: fatal: libXext.so.0: open failed: No such file or directory

a uz neviem dalej co s tym. Vsetky veci stahujem z sunfreeware.com. Nemozem pouzit nejaky pgk-get lebo ten stroj neni na internete. Nevie mi niekto plz helfnut?

SunOS webapp 5.9 Generic_112233-07 sun4u sparc SUNW,Sun-Fire-V240
igo
Junior

Odeslat příspěvekod nbusr123 29. 3. 2007 15:40

tak on se balickovaci system da pouzit i prestupu k internetu ze ...
tenhle vim si tam taky nejak musel dostat

btw o balickach v solarisu nic nevim ....
nbusr123
Junior

Odeslat příspěvekod duBeN 30. 3. 2007 07:13

pozri sa ci tam mas tu kniznicu /usr/lib/libXext.so.0

malo by to vyzerat takto nejako :

$ ls -l /usr/lib/libXext*
lrwxrwxrwx 1 root root 14 May 2 12:07 libXext.so -> ./libXext.so.0
lrwxrwxrwx 1 root root 27 May 2 12:07 libXext.so.0 -> ../openwin/lib/libXext.so.0


ld.so.1 is the "run-time linker"; it's the first piece of code run by dynamically-linked programs. (Moving it means that dynamically-linked programs that use the version you moved won't run, which is likely to mean that a lot of programs on your system won't run - and those might be programs that *HAVE* to run in order for your system to be able to start up.) When the program starts, it attempts to find all the shared libraries used by a program and map them into the address space of the process running the program.

The error message in question is coming *from* the run-time linker; the problem isn't that the system can't find the run-time linker, the problem is that the run-time linker can't find the libXext.so.0 dynamically-linked library.
duBeN
Junior
Uživatelský avatar

Odeslat příspěvekod igo 30. 3. 2007 07:53

no v tom bude ze nemam tie kniznice. nasiel som aj ja ze by to mohlo byt v openwin ale odkial to stiahnut a naco je to dobre pre vim..
igo
Junior

Odeslat příspěvekod igo 30. 3. 2007 08:22

aha, uz to mam. nakopcil som nejake kniznice ktore som stiahol z ftp://ftp.xfree86.org/pub/XFree86/4.6.0 ... s-sparc-9/.
Ale teraz som dosiel k novej chybe

ld.so.1: vim: fatal: libc.so.1: version `SUNW_1.22' not found (required by file vim)



Kód: Vybrat vše
bash-2.05# pvs /usr/lib/libc.so.1
        libdl.so.1 (SUNW_1.4, SUNWprivate_1.1);
        libc.so.1;
        SUNW_1.21.2;
        SUNW_1.21.1;
        SUNW_1.21;
        SUNW_1.20.4;
        SUNW_1.20.1;
        SUNW_1.20;
        SUNW_1.19;
        SUNW_1.18.1;
        SUNW_1.18;
        SUNW_1.17;
        SUNW_1.16;
        SUNW_1.15;
        SUNW_1.14;
        SUNW_1.13;
        SUNW_1.12;
        SUNW_1.11;
        SUNW_1.10;
        SUNW_1.9;
        SUNW_1.8;
        SUNW_1.7;
        SUNW_1.6;
        SUNW_1.5;
        SUNW_1.4;
        SUNW_1.3;
        SUNW_1.2;
        SUNW_1.1;
        SUNW_0.9;
        SUNW_0.8;
        SUNW_0.7;
        SISCD_2.3;
        SYSVABI_1.3;
        SUNWprivate_1.2;
        SUNWprivate_1.1;
igo
Junior

Odeslat příspěvekod nbusr123 30. 3. 2007 08:52

Ale teraz som dosiel k novej chybe

necekane :-D
nbusr123
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků