XP x64 Pro - Problem se zobrazovanim ceskych znaku v program

Na téma Windows XP, 2000, Me, 98, 95 a starší

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod cevacevikus 8. 4. 2009 15:24

Pri instalaci programu SolidEdge V18 se mi zacal sam od sebe vypinat system (v eventlogu je zaznam o selhani ovladace SENTINEL - HW klic,instalator tam hodil 32 bit verzi ovladace)

Po startu systemu se ale v hodne programech misto kodovani central european ukazuje azbuka misto ceskych znaku.

Pouzivam XP x64 SP2, vsechny aktualizace, bez ceske mui lokalizace, instalace bezi bez problemu od vanoc.

Office a dalsi jsou v poradku.

Ukazka je v obrazku:

http://ceva.rfa.cz/kodovani.png

Zkousel jsem zmenu v mistnim a jazykovem nastaveni pro non-unicode programy a nic se po restartu nezmenilo... Bod obnoveni pred instalaci neprovedl zadne zmeny.

Dekuji za jakoukoliv pomoc.

Ceva
cevacevikus
Kolemjdoucí

Odeslat příspěvekod Milanr1 8. 4. 2009 17:02

WXPP/64 je profi OS. Není tedy ošetřen proti blbosti BFU jako dětský OS Vista/64; předpokládá se, že admin ví, co dělá, když se v 64-bit OS přihlásí do admin-účtu a něco instaluje.
Co se přihodilo:
Stará 32-bit verze Solid Edge nahradila systémové fonty svými vlastními, nekompatibilními s daným OS.
Co s tím?
A/ Obnova OS ze zálohy z doby před instalací nekompatibilní verze programu:
ntbackup
Next
Restore Files nad Settings
Next
vyber potřebnou vezi zálohy OS.
Next
Restart OS.

B/ Pokud nemáš zálohu (= ostuda :-/):
opravná instalace OS
1) Boot z instalačního CD OS WXPP/64 SP2;
2) na 3. obrazovce:
R (= oprava OS)

C/ Jestliže hodláš instalovat nějaký program, vždy se předem ujisti, že je kompatibilní s daným OS.
V případě WXP/64 lze instalovat výhradně a pouze 64-bit verzi Solid Edge!!
Viz např.:
http://www.plm.automation.siemens.com/e ... ents.shtml
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod cevacevikus 8. 4. 2009 19:01

A/ Obnovil jsem složku fonts z nedělní zálohy, nepomohlo to... Takže už snad jedině celý systém...

B/ Data jsou pro mě důležitá, zálohuji na zvláštní disk a na média každý uzavřený projekt. Opravu bych dělal nerad, to bych řadši hodil clean install...

C/ Bohužel toto bylo hodně narychlo a dle toho to pak dopadlo... Jinak samotný SE V18 jede, jen ta azbuka všude...
cevacevikus
Kolemjdoucí

Odeslat příspěvekod Eagle 8. 4. 2009 19:25

A co zkusit odebrat fonty a znovu je nainstalovat? WinXP x64 standardně neinstaluje české fonty, tyto musí být doinstalovány uživatelem. Proto třeba nefunguje korektně čeština v Total Commanderu.
Eagle
Junior

Odeslat příspěvekod Milanr1 8. 4. 2009 19:59

Používám OS WXP/64 už 6 let, od 1. beta-verze:
1) nikdy jsem žádné „české“ fonty ani jinou podporu češtiny do tohoto OS neinstaloval;
2) nebylo toho třeba: české znaky fungují ve všech programech naprosto bezvadně, samozřejmě včetně TCMD;
3) „české“ fonty zajišťuje nastavené národní prostředí:
Control - Regional and Language Options - na všech kartách je „Czech“ jako default. Nic víc není třeba.
Naposledy upravil Milanr1 dne 8. 4. 2009 20:10, celkově upraveno 1
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod Milanr1 8. 4. 2009 20:02

cevacevikus píše:A/ Obnovil jsem složku fonts z nedělní zálohy

Samotná složka fonts nic neřeší. Nastavení fontů je určeno v registrech.
cevacevikus píše:... Takže už snad jedině celý systém...

Stačí záloha OS, jak už jsem psal výše: min. záloha registrů.
Milan
Milanr1
Pokročilý
Uživatelský avatar

Odeslat příspěvekod Eagle 8. 4. 2009 21:15

Já bohužel musel fonty vždycky doinstalovat, jinak to v některých softwarech blblo. V českých XPčkách ani Vistách jsem nikdy instalovat fonty nemusel.
Eagle
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků