Nefunkční Raspberry Pi 4

Počítačové periferie a další kategorie hardwaru, které nemají samostatnou sekci

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod eviljack 27. 12. 2021 13:08

Ahoj všem,

mám doma dvě RP 4, jedno funguje bez problému, ale druhé vůbec nenačte kartu a tím pádem ani nepustí signál do monitoru. Kontrolka u karty při zapnutí jednou problikne a to je vše, napájení svítí. Zkoušel jsem různé karty, i tu, se kterou druhé funguje. Dočetl jsem se, že by mohla pomoct výměna toho slotu, ale s tím nemám žádnou zkušenost.

Věděl byste někdo, co s tím, nebo to mám vyhodit? Koupil jsem jako funkční i s krabičkou, ale dotyčný evidentně dobře věděl, proč za to chce jenom 1.200,- Kč.
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod soban 27. 12. 2021 14:07

Vyzkoušej zda to nabootuje z externího SSD, novější RPI4 to umí pokud je tam novější eeprom.

Pokud je tam ještě stará eeprom která boot z externího SSD neumí tak pak ti nezbude nic jiného jak ten slot na kartu rozdělat a tu SD kartu tam nějak připojit a modlit se aby nebyly ty piny odpálené.

A nebo je druhá varianta že v té eeprom vypnul boot z SD karty, pak by to mělo z externího USB SSD nabotovat.
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod eviljack 27. 12. 2021 14:21

Zkusím, já jsem ho neměl doma, mám udělanou bootovačku z USB - zkoušel jsem na tom funkčním startovat Ubuntu 20.04 z USB 3.0, ale trvalo to strašně dlouho proti kartě, našel jsem, že to je chyba s ovladači, ale nepovedlo se mi to vyřešit, protože tomu prd rozumím :)
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod eviljack 27. 12. 2021 15:27

Měls pravdu, fakt to bylo vypnuté, teď už tam aspoň problikne ta úvodní obrazovka, udělám si bootovačku z další karty a uvidíme...
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod soban 27. 12. 2021 16:20

Pro pokusy tam vraž oficiální distribuci a když to bude chodit tak až potom skoušej alternativy.

Mě boot z SSD běží rychleji jak z SD - SD je proti tomu šnek :-)
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod eviljack 27. 12. 2021 16:35

Hm, tak bliká karta, zabliká i disk, rozsvítí se klávesnice a myš, pak to zhasne a konec, nevidím už ani obraz, zkusím si s tím pohrát večer.

edit: když tam není ani karta, ani disk, tak se ukáže aspoň ta obrazovka na pár vteřin.
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod soban 27. 12. 2021 18:13

Přímo na ten disk /dev/sda (sdb,sdcc,sdd.....) hoď image Raspberry Pi OS https://www.raspberrypi.com/software/op ... -os-32-bit

Vyzkoušej na funkčním RPI4 zda funguje a pak ho připoj na to nefunkční RPI4 a SD kartu vůbec nedávej do slotu!

Jak je SD karta ve slotu pokouší se to bootovat z SD karty.

Pro BOOT z USB nesmí být karta v SD slotu.
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod eviljack 27. 12. 2021 18:17

To je mi jasné, ale nejde to ani s tím, co běží na tom funkčním, jedno, jestli karta, nebo disk.

edit: je to divné, podle toho, kam zapojím myš a klávesnici, tak to buď blikne a ukáže obraz, nebo ani to, asi bude fakt v čudu.
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod soban 27. 12. 2021 18:25

Jestli neodrovnal ten USB řadič?

Taky ten SSD máš na USB3 nebo USB2?

Já to mám na USB3.
Naposledy upravil soban dne 27. 12. 2021 18:32, celkově upraveno 1
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod eviljack 27. 12. 2021 18:30

Vypadá to tak, nic jiného mě nenapadá - jednou z několika pokusů se to rozsvítí, pak zas x-krát myš jenom párkrá blikne a konec.
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod soban 27. 12. 2021 18:36

Pokoušíš se bootovat přes USB2 nebo USB3?

Mám vyzkoušené USB3 s USB3.

A i přes aktivní USB3 hub to bootuje - napájím přes něj i RPI4.

Tady asi bez osciloskopu a kontroly signálů na různých pinech asi nic nevymyslíš.....

Osobně bych to vrátil a neřešil......
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod eviljack 27. 12. 2021 18:39

Nenajede to ani z jednoho, ani z karty. Vracet to budu těžko, když to bylo kdoví od koho z netu, holt jsem si naběhnul. Tak můžu aspoň někomu střelit dvě krabičky, hehe - tady je ta originál černá a k druhému jsem dostal dvě tištěné + dotykový displej a stojánek.
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior

Odeslat příspěvekod meda2016 28. 12. 2021 07:43

@eviljack - Musí z testovací SD/flesky fungovat i boot na prvním ověřeném RPi4.

Pro pokus oživit nepřipojuj klávesnici ani myš, může být problém s napájením.
USB3 pro bootování pro jistotu zatěžuj bootem z flešky, ne z SSD disku (opět nevíme, jestli je napájení v pořádku).
meda2016
Junior

Odeslat příspěvekod eviljack 28. 12. 2021 07:58

Z obojího to druhé bootoje, tohle vadné nenajede z karty, flashky, ani SSD. Je tam stejná EEPROM, napájení používám stejný adaptér, dodaný k tomu - ten s vypínačem, ale zkoušel jsem i nabíječku s USB-C a 3.1A, přes kterou opět to funkční normálně běží, a dock, asi je v čudu ten USB řadič.

Už jsme to se sobanem vymysleli, takže to můžeš pustit z hlavy :) Díky.
Harman Kardon 6500 + WTX Microstreamer + Heco Aurora 700
Yamaha RX-V765 + Heco Metas 500 set + Heco Krypton Subwoofer
Projektor Benq W1090
Asustor AS6102T
eviljack
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků