Problém s C# builderem - chyba při spuštění

C++, C#, Visual Basic, Delphi, Perl a ostatní

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod Petr S. 2. 10. 2006 21:04

Zdravím,

mám hrozný problém a to ten, že za žádnou cenu nemohu na svém počítači rozchodit C# builder pořád to jen při spuštění hlásí otravnou hlášku

Initializing the .NET host environment failed with message:
Nespecifikovaná chyba, ClassID: {CD2A1B3E-175C-4DA3-A55F-6FB4E21C5B3F}

Builder se pak sice spustí, ale je mi to k ničemu, protože v něm nelze žádný soubor se zdrojovým kódem vytvořit ani otevřít... :-(

Už jsem zkoušel snad všechno. Mockrát jsem to už zkoušel přeinstalovávat včetně .NETu SDK 1.1 i samotného .NETu 1.1, ale nic nezabírá...

Už fakt nevím co s tím! Poradíte? Setkal se již někdo s podobným problémem?

Díky za každou pomoc

EDIT: Původně jsem měl potíže i se samotnou instalací, tak je možné, že mám i špatné instalační soubory, ale pár mých známých to již ze stejné instalačky rozchodilo... Na druhou stranu kupa jiných zas ne... Nevíte, kde by se dala sehnat jiná instalačka C# Builderu?
Alea iacta est! Kostky jsou vrženy!
Petr S.
Junior
Uživatelský avatar

Odeslat příspěvekod Petr S. 6. 10. 2006 14:49

Neví někdo?
Alea iacta est! Kostky jsou vrženy!
Petr S.
Junior
Uživatelský avatar

Odeslat příspěvekod hanes.strnad 6. 10. 2006 19:29

muzu te poradit jedno...bud si to kup nebo zkus todle http://www.icsharpcode.net/OpenSource/SD/
je to open source a ja sem s nim naprosto spokojenej
hanes.strnad
Junior
Uživatelský avatar

Odeslat příspěvekod Petr S. 6. 10. 2006 19:35

S licencí by být problém neměl, protože je to nekomerční verze pro studenty (noncommercial). K tomu mám i registrační soubor, který je třeba nakopírovat do složky profilu...

Jo, na tenhle program jsem též narazil a zkoušel si jej nainstalovat, bohužel též s neúspěchem - instalace klasicky proběhne až do konce, ale právě na konci se produkt zase odinstaluje a oznámí, že se nemohl nainstalovat, přičemž ani nevyhodí hlášku s informací, kde by mohl být problém...
Alea iacta est! Kostky jsou vrženy!
Petr S.
Junior
Uživatelský avatar

Odeslat příspěvekod hanes.strnad 6. 10. 2006 21:04

a jakou verzi .NET framework mas nainstalowanou ? pac problem bude asi v ni...nainstaluj si 2.0 a nemel by byt problem
hanes.strnad
Junior
Uživatelský avatar

Odeslat příspěvekod Petr S. 6. 10. 2006 21:13

nejdřív jsem tam zkoušel dávat .NET 2.0 ale to se to nechtělo ani nainstalovat. takze tam mam ted .NET 1.1.

Ted se mi ale zda ze problem by mohl byt prave v tom ze jsem tam mel driv 2.0 (taky jsem zkousel zprovoznit beta verzi MS Visual Studia 2005, což se mi ale taky nepovedlo :-( tak jsem to odinstaloval, vcetne toho .NETu - ale zda se ze se odinstaloval nejak divne... nevim jak je to ale mozne a proto to ted mozna nejede...
Alea iacta est! Kostky jsou vrženy!
Petr S.
Junior
Uživatelský avatar

Odeslat příspěvekod Petr S. 7. 10. 2006 16:56

Tak už jsem na to přišel! Bylo to tim že se to opravdu špatně odinstalovalo :-( Když jsem tam doinstaloval .NET 2.0, tak ta otravna hláška zmizela a SharpDevelop mi už jede taky.

Systém byl nějak divně přesvědčen, že mam .NET 2.0, ale já ho přitom neměl nainstalovaný. Prostě divný! Když jsem chtěl .NET 2.0 nainstalovat tak se mě to zeptalo jesli ho chci opravit (tzn. že ho mám již nainstalován... ale ja ho nemel...).
Alea iacta est! Kostky jsou vrženy!
Petr S.
Junior
Uživatelský avatar

Odeslat příspěvekod hanes.strnad 8. 10. 2006 15:18

gratuluju.... :D
hanes.strnad
Junior
Uživatelský avatar

Odeslat příspěvekod Petr S. 8. 10. 2006 15:21

dikes :-D
Alea iacta est! Kostky jsou vrženy!
Petr S.
Junior
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků