VLAN - MK3011 + Switch TPLink + UBNT APs

Poskytovatelé a technologie, dial-up, ADSL, kabel, optika, bezdrátové připojení

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod googler1 13. 8. 2019 15:21

Caute mam problem (zase :D )

Snazim sa nakonfigurovat VLAN na mikrotiku RB3011 + TPLink TL-SG1016PE + Ubiquiti APcka. Ide o normalnu situaciu kedy jednu VLAN potrebujem mat privatnu s plnym pristupom do LAN a na internet + bude na nej samozrejme aj wifi SSID. Druhu VLAN potrebujem pre hosti v ktorej budu len APcka (oddelene SSID) cez ktore bude mat host pristup na net bez pristupu do LAN. Casom mozno budem chciet dalsie VLANy podla potreby.

Momentalne je modem v MK zapojeny v ETH1 + v MK je vytvoreny PPPoE client (WAN). V MK je v ETH2 (LAN) zapojeny uz iba TPLink switch a vsetko ostatne je zapojene v tom TPLinku.


Vlany na tplinku a MK som nastavil a zatial je vysledok taky ze na kabloch mi net ide (aj DHCP funguje ako ma) ale na UBNT APckach nie. Neviem preco - pripojim sa aj na guest aj na privat ale net nejde + na wifi klientoch mi neprideli ip podla dhcp poolu v MK ale nejaku "nahodnu" ip. Navyse wifi klienti maju inu masku (mali by mat 255.255.255.0 ale maju 255.255.0.0) takze ani nemam ako otestovat ci vlany splnia ucel oddelenej siete. Na MK som postupoval podla tohto videa:
https://www.youtube.com/watch?v=T0y1F3JmSZc s tym rozdielom ze ako adresy pre vlany som pouzil 192.x.x.x namiesto 10.x.x.x a WAN ip som nevytvaral lebo uz bola vytvorena automaticky (v MK sa zobrazuje okrem adries vlan aj verejna ip od isp) + som vytvoril pre obidve vlany dhcp server a pool cez dhcp setup v MK + do FW som doplnil forward pravidla na zakaz pristupu z guest do privatu

V pripade tplinku som postupoval podla tohto videa https://www.youtube.com/watch?v=T0y1F3JmSZc V privatnej vlan su tagovane len porty routera a APciek ostatne porty su untag. V guest Vlan su pridelene len tagovane porty routera a APciek (ziadne ine porty v gueste nie su). Co sa tyka PVID tak v PVID 1 su porty routera a APciek. Spravil som to tak pretoze som iekde cital ze v TPlinku je PVID 1 nieco ako alternativa pre trunk Ostatne porty maju potom pridelene PVID privatu V UBNT CTR som potom uz len v casti network vytvoril dve corporate siete s identickymi adresami vlan a pridelil som im vlan id a vypol DHCP. Nasledne som v casti Wireless network vytvoril dve SSID znova s prislunymi vlan id. Stale mi ide net iba "po kabloch" ale cez AP nie. Skusal som aj moznost namiesto profilu corporate network pouzit profil vlan only ale ani to nepomohlo.
googler1
Junior

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků