AHCI nebo native IDE

Pevné disky, CD, DVD a BR mechaniky, USB flashdisky, paměťové karty a další

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod Oggi09 20. 12. 2011 12:18

V pc mám seagate 7200.12 (1TB), intel 320 (80GB) a desku se SATAIII.

Je rozumnější používat v kombinaci obou disků nativní IDE režim, nebo kvůli SSD raději AHCI? Resp. má smysl obě zařízení připojovat přes SATAIII i když jej rychlostně nevyužijí?

Díky.
Oggi09
Junior
Uživatelský avatar

Odeslat příspěvekod cheeta 20. 12. 2011 12:28

Malé info - při změně režimu to systém nemusí rozdýchat....
GA P35-DS3L, Core2Duo E8400, 2x2 GB, 2x 1TB RAID-0, WinFast DTV 1000S
Toshiba L300
cheeta
Junior

Odeslat příspěvekod rejpal 20. 12. 2011 12:33

Ano při změně AHCI nebo IDE.. System nenajíždní a resetuje se.. Stačí vrátit původní nastavení která byla při instalaci systemu a vše zase jede..Aspon u mě. Je zajímavý že notebook to normálně rozchodí a nic se neděje.. A stolní PC i7 950, MB P6T_Deluxe_V2 ani náhodou.. Vše je závislé na hardware ;-]
Jinak modernější je AHCI pokud ti to hardware dovolí ;-] ... Tedy mělo by to bejt rychlejší.. Popravdě žádnej markantní rozdíl v tom neni..
Nedělejte to jako já a v ničem se zbytečně nerýpejte!!! RejpalX
rejpal
Junior
Uživatelský avatar

Odeslat příspěvekod KineCZek 20. 12. 2011 12:40

AHCI a pripoj kam chces, ale ne na ten pridavny radic.
Don't think you are. Know you are. (Morpheus)

PC sestavy hracum i profesionalum na miru - nyni nove i na Facebooku. (KineCZek Work)
KineCZek
Odborník PC sestav a ULN, Ex-administrátor
Uživatelský avatar

Odeslat příspěvekod Nargon 20. 12. 2011 13:27

Co se tyce prepinani IDE, AHCI a nenabehnuti systemu, tak je problem v ovladacich.
Pokud system nema nainstalovane Sata ovladace tak v ahci rezimu system nenajde disk a nemuze bootovat. A to je cely problem.
Pokud se system instaloval pri zapnutem AHCI rezimu, tak se nainstalovali i ty ovladace. A pak si muzete prepnout na IDE rezim a system normalne nabehne (na ide nejsou potreba zadne special ovladace). A pak si muzes prepnout zase zpet na AHCI a vse funguje, protoze ty ovladace v systemu zustaly.
Problem je pokud se system instaluje na IDE rezim, pak ovladace chybi a pri prepnuti na AHCI system nenabehne. Jedina moznost je do systemu nejprve nacpat ty ovladace a az pak prepnout na AHCI rezim. Bohuzel nevim jak, nikdy jsem to nepotreboval resp ja pouzivam ahci rezim trvale, tak byl pritomen i pri instalaci systemu. Ale snad by se dalo neco vygooglit.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor

Odeslat příspěvekod Oggi09 20. 12. 2011 21:39

No lze to i po instalaci pomocí změny v registrech: v HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
změnit hodnotu Start ze 3 (Zakázáno) na 0 (Povoleno)

Takže když oba hodím do těch bílých SATAIII a povolím AHCI tak to bude ideální;)
Oggi09
Junior
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků