Excel - Proč nefunguje podmíněný součet (fce SUMIF)?

Programy pro práci s textem, tabulkami, prezentacemi

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod jiri.filip 19. 5. 2017 10:24

Ahoj,

potřebuji, aby mi funkce SUMIF podmíněně sčítala částky zaúčtované max. do data uvedeného v poli U1, které je naformátováno na dd.mm.rrrr.

Syntaxi středního argumentu funkce v uvozovkách jsem našel v on-line nápovědě Excelu.

Očekával jsem, že mi vzorec v buňce T32253 vrátí správnou hodnotu 12.928,10 Kč. Místo toho ovšem zobrazuje nulu.

V buňce U32253 je pomocí běžné sumační funkce zobrazena správná hodnota uvedená výše v textu.

Předem díky za tip, proč vzorec SUMIF v tomto případě nepracuje správně.
Přílohy
Nefunkční SUMIF_201705.png
Nefunkční SUMIF_201705.png (11.17 ) Zobrazeno 3952 krát
jiri.filip
Junior

Odeslat příspěvekod Kurimak 24. 5. 2017 07:27

Funkce SUMIF považuje výraz
Kód: Vybrat vše
"<=$U$1"
za text. Řešením je vložit místo něj skutečnou hodnotu datumu místo odkazu na buňku nebo použít vzorec:
Kód: Vybrat vše
=KDYŽ($A$32252:$A$32255<=$U$1;SUMA(($E$32252:$E$32255))
Kurimak
Junior

Odeslat příspěvekod tomas.kacha 26. 5. 2017 14:06

Existuje jednodušší řešení. Stačí výraz upravit na "<="&$U$1 (neboli spojení 2 textových řetězců) a bude to fungovat.
tomas.kacha
Kolemjdoucí

Odeslat příspěvekod Kurimak 31. 5. 2017 12:58

Děkuji za radu. Aspoň jsem se zas něco přiučil.
Kurimak
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků