Stránka 1 z 1

Excel - Proč nefunguje podmíněný součet (fce SUMIF)?

Odeslat příspěvekNapsal: 19. 5. 2017 10:24
od jiri.filip
Ahoj,

potřebuji, aby mi funkce SUMIF podmíněně sčítala částky zaúčtované max. do data uvedeného v poli U1, které je naformátováno na dd.mm.rrrr.

Syntaxi středního argumentu funkce v uvozovkách jsem našel v on-line nápovědě Excelu.

Očekával jsem, že mi vzorec v buňce T32253 vrátí správnou hodnotu 12.928,10 Kč. Místo toho ovšem zobrazuje nulu.

V buňce U32253 je pomocí běžné sumační funkce zobrazena správná hodnota uvedená výše v textu.

Předem díky za tip, proč vzorec SUMIF v tomto případě nepracuje správně.

Re: Excel - Proč nefunguje podmíněný součet (fce SUMIF)?

Odeslat příspěvekNapsal: 24. 5. 2017 07:27
od Kurimak
Funkce SUMIF považuje výraz
Kód: Vybrat vše
"<=$U$1"
za text. Řešením je vložit místo něj skutečnou hodnotu datumu místo odkazu na buňku nebo použít vzorec:
Kód: Vybrat vše
=KDYŽ($A$32252:$A$32255<=$U$1;SUMA(($E$32252:$E$32255))

Re: Excel - Proč nefunguje podmíněný součet (fce SUMIF)?

Odeslat příspěvekNapsal: 26. 5. 2017 14:06
od tomas.kacha
Existuje jednodušší řešení. Stačí výraz upravit na "<="&$U$1 (neboli spojení 2 textových řetězců) a bude to fungovat.

Re: Excel - Proč nefunguje podmíněný součet (fce SUMIF)?

Odeslat příspěvekNapsal: 31. 5. 2017 12:58
od Kurimak
Děkuji za radu. Aspoň jsem se zas něco přiučil.