Excel vzoreček - aneb hádanka pro Vás :)

Programy pro práci s textem, tabulkami, prezentacemi

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod PetrikCZ (novy) 1. 12. 2005 16:14

Ahoj
Mám schánku po vzorečku do Excelu, který by uměl spočítat dobu mezi dvěma datumy. A to bez svátků a víkendů. (patrně nějaká funkce, co umí spolupracovat s kalendářem)

Vypadá to jednoduše, ale asi to zas tak jednoduché není.

Příklad začátek(sloupec A): 30.09.2005 konec(sloupec B): 31.10.2005 doba trvání (sloupec C): 20

aby to nebylo tak "easy", tak jsou tu ještě pravidla
- nikdy to není 0, vždy to trvá alespoň jeden den (např. od 1.1.05 do 1.1.05 je mamtematicky 0, ale prakticky 1 den)

-první den se nepočítá, pokud je i další (např. od 1.1.05 do 2.1.05 je také jeden den trvání a ne dva)

------

Tak co ? znáte takový vzoreček ? :)

NEPTÁM SE JEN TAK - MÁM TO DO PRÁCE - MOC BYSTE MI TÍM POMOHLI !

představte si Excel sheet s 300 řádky, kde toto musím počítat "růčo" :(

[i]Howard - presunuto[i]
Mějme se rádi - je to příjemný...
PetrikCZ (novy)
Kolemjdoucí

Odeslat příspěvekod misel1 1. 12. 2005 16:18

šlo by použít fci dentýdne ta zjistí kolikátý den v týdnu to je tzn. budeš pak počítat pouze dny 1 až 5 a co se týče svátků? Excel nezná svátky musí se naimportovat buď si udělaš nějaký seznam a fcí když to budeš vylučovat nebo pak makro a pole ale jeden vzorec to rozhodně nebude
Moje hračka? Walther P99 a Sa-58 V
misel1
Junior
Uživatelský avatar

Odeslat příspěvekod penemy 1. 12. 2005 20:18

ja by som to spravil takto:

=KDYŽ(A1=B1;1;ROK360(A1;B1)-"pocet sviatocnych dni")
- ak sa prva bunka rovna druhej, tak je pocet dni 1, inak pouzi funkciu na vypocet dni medzi datumami a odrataj sviatocne dni

to som len tak pozrel v praci (blby excel s ceskymi vzorcami), ale viem, ze ked som si pozeral OpenOffice, tak tam bola funkcia aj pre vypocet pracovnych dni
ziadny dobry skutok nezostane nepotrestany..
penemy
Junior
Uživatelský avatar

Odeslat příspěvekod PrceK_P 2. 12. 2005 08:06

V nápovědě k excelu jsem našel funkci "NETWORKDAYS" (mělo by to být to, co potřebuješ), ale nikdy jsem ji nepoužíval, takže netuším co a jak.
PrceK_P
Junior
Uživatelský avatar

Odeslat příspěvekod misel1 2. 12. 2005 08:25

penemy píše:ja by som to spravil takto:

=KDYŽ(A1=B1;1;ROK360(A1;B1)-"pocet sviatocnych dni")
- ak sa prva bunka rovna druhej, tak je pocet dni 1, inak pouzi funkciu na vypocet dni medzi datumami a odrataj sviatocne dni

to som len tak pozrel v praci (blby excel s ceskymi vzorcami), ale viem, ze ked som si pozeral OpenOffice, tak tam bola funkcia aj pre vypocet pracovnych dnii/quote]


a co víkendy? musíš ještě zjistit o jaký den se jedná. A odečíst jen svátky to taky není úplně pravda. musíš zjistit jestli ten svátek je v tom rozsahu datumů
Moje hračka? Walther P99 a Sa-58 V
misel1
Junior
Uživatelský avatar

Odeslat příspěvekod fsobi 2. 12. 2005 09:12

Ja jsem toto řešil tež v práci.Mám na to makro.Někdy jsou potíže použít funkci "NETWORKDAYS".Makro spočítá vše bez potíží.
fsobi
Kolemjdoucí

Odeslat příspěvekod PetrikCZ (novy) 7. 12. 2005 12:09

... to makro zní dobře.
Nebylo by možno ho zaslat na info@dileris.cz ?
Pokud možno i s tabulkou, kde je to vidět, abych to snáze vstřebal


Předem díky :)
Mějme se rádi - je to příjemný...
PetrikCZ (novy)
Kolemjdoucí

Odeslat příspěvekod PetrikCZ (novy) 9. 12. 2005 08:38

Díky moc všem zůčastněným - už jsem obdržel perfektní verzi.

Pokud by měl někdo totožný problém, napište mi na info@dileris.cz
a předám.
Mějme se rádi - je to příjemný...
PetrikCZ (novy)
Kolemjdoucí


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků