Veřejná IP adresa nastavení

Routery, AP, switche, huby, ethernet

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod Czuba 21. 1. 2010 13:28

Ahojte lidičky,
mám problém, provider mi poslal tento e-mail :
Vasa verejna IP na pristup do vasej siete je 80.82.xxx.xx a je prelozena
na Vas router 192.168.xxx.x.
Musite si ale na routri urobit mapovanie do vnutra siete, aby to islo
dalej...

Já teď ale nevím co vubec po mně chce. Mám jeden router od nich, na který se já nedostanu a pak do něj mám dva své. Poradíte mi prosím co mám udělat?
Routery mám tyto:
Ovislink WL-5460 AP v2
Micronet SP916GK v5
Hrozně moc děkuju za pomoc
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod Wikan 21. 1. 2010 13:35

Nastavit to musíš na tom routeru od providera.
Wikan
Moderátor
Uživatelský avatar

Odeslat příspěvekod p0etrik 21. 1. 2010 13:39

Tady bude tech problemu vic. Ja treba zas netusim, co vlastne chces ty, aby to delalo. Nejak jsi to zapomel napsat.
p0etrik
Junior

Odeslat příspěvekod x_based 21. 1. 2010 13:46

Trochu nepřesně napsané, provider ti přidělil veřejnou ip adresu, tu by si měl mít nastavenou na routeru, pokud si jí nevzal pomocí DHCP.
To znamená že router je viditelný z internetu, ale ostatní počítače za ním nejsou přímo přístupné, proto musíš zařídit přesměrování portů NATem, ikdyž dnes již všechny routery mají UPnP (i software utorrent) pro automatické přesměrování. Některé routery mají i funkci DMZ kdy jedno PC odhalí do internetu a router je jakoby transparentní.
pro testování portů můžeš použít http://canyouseeme.org/
x_based
Junior

Odeslat příspěvekod Nargon 21. 1. 2010 13:48

Mno zalezi jak je nastavene cislovani a vlastne cela sit.
Mozna ze provider prave nastavil ten svuj router (do ktereho Czuba uz nemuze).
Overit to jde jedinym zpusobem.
Tu IP adresu co vam zdelil vas provider (tj ta 192.168.xxx.x) tak se musite podivat jestli ji mate pridelenou na jednom z tech vasich routeru na WAN portu.
Pravdepodobne na jednom routeru bude. Pak samozrejme na tom routeru (mozna obou, buh vi jak to mate doma zapojene) musite nastavit to mapovani dal. Pro presnejsi radu by to ale chtelo znat topologii vasi domaci site.
Desktop: Ryzen 7 1800X (3.95GHz, 1.35V), Asus Crosshair VI Hero, 16GB DDR4 Ram (3200MHz), 128GB SSD + 3TB HDD, Nvidia GTX 1080
Notebook: Asus UL50VT 15.6" (SU7300@1.7GHz, 4GB ram, 500GB HDD, Intel GMA 4500MHD + nVidia G210M, dlouha vydrz cca 7+ hod)
Nargon
Moderátor

Odeslat příspěvekod vladimir 21. 1. 2010 14:01

Na začátek, abychom si ujasnili pojmy: Ovislink 5460 není router ani wifi-router, ale jenom acces point.

Navrhuji: připojit počítač, ketrý má nastaveno automatické přebírání nastavení z DHCP, kabelem k providerovu routeru a podívat se, co dostane přiděleno. Od toho se bude odvíjet další topologie sítě - předpokládám, že optimální a postačující bude použít dva acces pointy.

Nastavení počítače po připojení k providerově routeru se zjistí příkazem ipconfig -all

To Czuba: ten text mailu jsi sem přepsal doslova a celý? (IP-adresu si klidně zakřížkuj, ale technické podrobnosti připojení nezkracuj).
Naposledy upravil vladimir dne 21. 1. 2010 14:07, celkově upraveno 1
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 21. 1. 2010 14:06

Zažádal jsem ISP o přidělení veřejné IP adresy, on že dobře a že se pokusí to dát co nejrychleji dohromady. Poslal mi tento e-mail a to vše. Nic víc nic míň.
Pokud tento obrázek postačí jako topologie?
Obrázek
WAN jde do Micronetu, a tam je přidělena pevně, jelikož DHCP není urřitě povolen.
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 21. 1. 2010 14:16

Zajímá mě IP-adresa Micronetu na obou stranách (LAN i WAN) a IP-adresa, brána a DNS počítače, kterou dostane po připojení přímo k providerovi.

Dále mě zajímá IP-adresa, kterou ti mapuje provider (ta 192.168.x.x - ale skutečná, nepřepisuj čísla písmeny X - vždyť je to adresa vnitřní sítě.)


Jo a vlastně zásadní otázka: teď ti internet funguje?
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 21. 1. 2010 14:35

Takže jsem zkoušel o přidělení adresy z routru od providera a nic. Nepřidělí. Musím nastavit jedině ručně.
Z Microtiku:
WAN
IP Address: 192.168.111.2
Subnet Mask: 255.255.255.252
Default Gateway: 192.168.111.1
DNS 1: 80.82.144.242
LAN
IP Address: 192.168.4.1
Subnet Mask: 255.255.255.0
DHCP server: Enabled
DHCP Client Range: 192.168.4.5 - 192.168.4.29
802.1d Spanning Tree: disabled
Enable UPnP - není zaškrtnuto

Ano internet mi funguje. Snad je to vše

edit///

výpis z Ipconfig/all
Konfigurace protokolu IP systému Windows

Název hostitele . . . . . . . . . : Siki-kancl
Primární přípona DNS. . . . . . . :
Typ uzlu . . . . . . . . . . . . : hybridní
Povoleno směrování IP . . . . . . : Ne
WINS Proxy povoleno . . . . . . . : Ne

Adaptér sítě Ethernet Připojení k místní síti:

Přípona DNS podle připojení . . . :
Popis . . . . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E G
net Controller
Fyzická Adresa. . . . . . . . . . : 00-1E-8C-B5-45-3E
Protokol DHCP povolen . . . . . . : Ne
Automatická konfigurace povolena : Ano
Adresa IPv4 . . . . . . . . . . . : 192.168.4.30(Preferované)
Maska podsítě . . . . . . . . . . : 255.255.255.0
Výchozí brána . . . . . . . . . . : 192.168.4.1
Servery DNS . . . . . . . . . . . : 80.82.144.242
Rozhraní NetBios nad protokolem TCP/IP. . . . . . . . : Povoleno
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 21. 1. 2010 14:56

na Vas router 192.168.xxx.x - tedy na router 192.168.111.2 ?

(Ten Mikrotik, o kterém teď píšeš, je ten tvůj Micronet?)
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 21. 1. 2010 15:07

Jj Micronet a ano na router 192.168.111.2
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 21. 1. 2010 15:16

No tak já už snad mám jasno. Provider postavil tvůj mikrotik 192.168.111.2 do DMZ (demilitarizované zóny) a na tuto adresu jsou přesměrovávány všechna připojení z té veřejné adresy.

Ty teď musíš v Mikrotiku jenom takzvaně otevřít porty, abys mohl začít využívat výhody veřejné adresy (abys mohl přijímat připojení z internetu).

Aby to fungovalo, musí mít počítač, pro který chceš otevírat porty, stálou IP-adresu (ručně nastavenou nebo v mikrotiku nastavenou vazbu mezi IP a MAC).

Příkald: tcp port 5900 otevřeš pro počítač 192.168.4 100 tímto příkazem:
Kód: Vybrat vše
/ip firewall nat add chain=dstnat dst-address=192.168.111.2 protocol=tcp dst-port=5900 \
    action=dst-nat to-addresses=192.168.4.100 to-ports=5900
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 21. 1. 2010 15:22

Pokud vím, tak v microtiku je nastavena pevná IP adresa ale MAC adresa určitě nee. Ten kód zadám do cmd že? Nebo někam jinam? Právě že nejsem zběhlý v síťařině a domluvit s providerem aby mi to šel nastavit je jako házet hrách na zeď, člověk se snaží a žádná odpověď :(

//edit///

a jak vypadá příkaz abych to mohl zrušit? Kdyby náhodou a jde to nastavit aby všichni měli niby jako veřejnou IP adresu? Myslím třeba nastavit to pro ten micronet AP?
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 21. 1. 2010 15:54

V mikrotiku lze nastavit, aby počítač s určitou adresou dostával od DHCP serveru vždy stejnou IP-adresu. Buď to uděláš, nebo musíš nastavit IP-adresy ručně. (Ve Winboxu v nastaveních DHCP, položka Bind nebo tak nějak)

Kód zadáš do konzoly Mikrotika (ve Winboxu).

Zrušení: ve Winboxu si otevřeš okno firewalu, označíš ten tvůj řádek a smažeš ho.

Nikdo nemůže mít veřejnou IP-adresu, nanejvýš jeden počítač by mohl taky být postaven do DMZ. Za normálních okolností to ani není potřeba: pokud někdo chce například stahovat přes torent na TCP portu 55555, tak mu ho prostě otevřeš. (Poznámka: Dva počítače nemohou používat stejný port.)

Czuba píše:a domluvit s providerem aby mi to šel nastavit je jako házet hrách na zeď, člověk se snaží a žádná odpověď
Teď, když máš veřejnou IP-adresu, nemusí chodit, může to udělat přes internet ze svého počítače ( může to udělat kdokoliv, komu sdělíš IP-adresu a heslo pro administraci, pokud nemáš zablokovanou administaci z WAN.).
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 22. 1. 2010 00:14

Problém je v tom že já se ne mikrotik nedostanu. Neznám user ani pass. :(
Asi řeknu tomu správci ať to udělá že si s tím nevím rady :(

//edit//
mno možná že už to trochu chápu. Ale jen trochu. I kdybych se připojil k tomu mikrotiku pomocí IP adresy z WAN na micronetu, tak se nedostanu do Mikrtiku z winboxu jelikož neznám heslo atd. Je to pravda, nebo se mýlím. Dále bych se chtěl zeptat, když mám v síti 5 počítačů, kolika z nich mohu nastavit aby mohli používat veřejnou IP adresu? Nebo spíš jaké porty to jsou? To je za trest vysvětlovat neco magorovi co? :D
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 22. 1. 2010 08:50

ANo, máš pravdu, bez hesla nelze Mikrotik nastavit.

Veřejnou (v tomto připadě pseudoveřejnou) adresu by mohl mít jeden jediný počítač, kdyby byl postavený v DMZ, to značí, že veškerá připojení z internetu by byla forwardována (přesměrována) na ten počítač. Ale v takovém případě by ostatní měli zcela neveřejnou adresu.

Pro sítě podobé tvé se používá forwardování konkrétních portů na konkrétní počítače. Počet takových přesměrování je omezený jenom možnostmi Mikrotika, odhaduji to na možnost nadefinování až stovek přesměrování (forwardování).

Ty si musíš udělat "inventuru", jaké porty na jaký počítač potřebuješ nasměrovat a ten seznam předáš providerovi a ten ti to nadefinuje.

Pokud ti provider povolil v mikrotiku UPnP, tak si umí některé programy forwardovat porty automaticky.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod mehturt 22. 1. 2010 13:20

vladimir píše:Na začátek, abychom si ujasnili pojmy: Ovislink 5460 není router ani wifi-router, ale jenom acces point.

vie fungovat aj ako router, od verzie firmware tusim 11
mehturt
Kolemjdoucí

Odeslat příspěvekod vladimir 22. 1. 2010 14:48

mehturt píše:vie fungovat aj ako router, od verzie firmware tusim 11
No vita, to abych si na to svém updatoval firmware :-[
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod mehturt 22. 1. 2010 15:00

ano, tiez som o tom nevedel kym kamarat s UPC modemom chcel pripojit do siete 2 pocitace
mehturt
Kolemjdoucí

Odeslat příspěvekod richi_bb 22. 1. 2010 22:10

vladimir píše:No tak já už snad mám jasno. Provider postavil tvůj mikrotik 192.168.111.2 do DMZ (demilitarizované zóny) a na tuto adresu jsou přesměrovávány všechna připojení z té veřejné adresy.

Ty teď musíš v Mikrotiku jenom takzvaně otevřít porty, abys mohl začít využívat výhody veřejné adresy (abys mohl přijímat připojení z internetu).

Aby to fungovalo, musí mít počítač, pro který chceš otevírat porty, stálou IP-adresu (ručně nastavenou nebo v mikrotiku nastavenou vazbu mezi IP a MAC).

Příkald: tcp port 5900 otevřeš pro počítač 192.168.4 100 tímto příkazem:
Kód: Vybrat vše
/ip firewall nat add chain=dstnat dst-address=192.168.111.2 protocol=tcp dst-port=5900 \
    action=dst-nat to-addresses=192.168.4.100 to-ports=5900

Ja by som to este zjednodusil
Tymto si otvoris vsetky porty pre tvoj PC a nemusis pisat tolko riadkov (Porty do 1024 pouzivaju aplikacie typu www, ftp a pod. tak preto od 1024)
Kód: Vybrat vše
/ip firewall nat add chain=dstnat dst-address=192.168.111.2 protocol=tcp dst-port=1024-65535 action=dst-nat to-addresses=192.168.4.100 to-ports=1024-65535
/ip firewall nat add chain=dstnat dst-address=192.168.111.2 protocol=udp dst-port=1024-65535 action=dst-nat to-addresses=192.168.4.100 to-ports=1024-65535

Ten prvy kod je ale lepsie pouzit pokial potrebujes iba konkretny port presmerovat dnu, je to bezpecnejsie.
Ale inak neviem naco ste to tu pisali kedze ten chalan ma Micronet SP916GK v5 a nie Mikrotik. :-)
richi_bb
Kolemjdoucí

Odeslat příspěvekod vladimir 22. 1. 2010 22:17

richi_bb píše:
Kód: Vybrat vše
/ip firewall nat add chain=dstnat dst-address=192.168.111.2 protocol=tcp dst-port=1024-65535 action=dst-nat to-addresses=192.168.4.100 to-ports=1024-65535
/ip firewall nat add chain=dstnat dst-address=192.168.111.2 protocol=udp dst-port=1024-65535 action=dst-nat to-addresses=192.168.4.100 to-ports=1024-65535
Jde o více počítačů, patřících více lidem, dá se předpokládat, že každý bude chtít otevřít nějaký port, takže otevřít všechny porty jednomu počítači je kontraproduktivní. Ale jako příklad otevření skupiny portů je to O.K.


richi_bb píše:Ale inak neviem naco ste to tu pisali kedze ten chalan ma Micronet SP916GK v5 a nie Mikrotik. :-)
Pokud Czuba nemá mikrotik, jak začal uprostřed diskuze tvrdit,(ještě jsem se ho extra ptal), tak ani já nevím, proč jsem se namáhal :D :D :D

A stejně nemá přístup...
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 23. 1. 2010 21:38

Mikrotika má ISP, na který já přístup nemám. To jsem tady psal Vladimíre.
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 23. 1. 2010 22:09

Takto jsem se ptal:
vladimir píše:Ten Mikrotik, o kterém teď píšeš, je ten tvůj Micronet?

No, to už je jedno. Provider postavil tvůj Micronet 192.168.111.2 do DMZ (demilitarizované zóny) a na tuto adresu jsou přesměrovávány všechna připojení z té veřejné adresy.

Porty se budou forwardovat (přesměrovávat, otevírat, vytvářet virtuální servery) v tom Micronetu, viz strana 47 a 48 anglického návodu.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 24. 1. 2010 17:05

Vladimir: omlouvam se, špatně jsem to pochopil, vina je na mé straně.
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod Czuba 24. 1. 2010 23:26

Vladimir: mohl by jsi mi dat odkaz na ten manual? Nemohu ho nikde najit. Diky moc
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod Czuba 27. 1. 2010 19:15

TXH vladimir :-)
Takže já si to nastavil takto. Mám to dobře?
Obrázek

ve virtual dmz mam nastavit co? Mám vůbec něco nastavovat? je tam toto:
Obrázek

Díky
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 27. 1. 2010 20:13

Pokud chceš všechny porty přesměrovat na svůj počítač 192.168.4.30 (udělat si z něj jakoby veřejnou IP-adresu), tak to máš O.K..
Nezpřístupnil sis porty 1 - 1023, takže si nemůžeš vytvořit www server nebo ftp server. Pokud bys chtěl takový server vytvořit, musel by sis povolit porty od jedničky, a to bys rovnou mohl svůj počítač postavit do DMZ - to je ten druhý obrázek.

Jenom nezapomeň, že jsi svůj počítač právě vystavil všem možným útokům z internetu, takže si dej pozor na konfiguraci softwarového firewalu.

Pokud bys povolil i porty 1-1023, byla by možnost napadení z internetu ještě větší.

Proč si vůbec povoluješ všechny porty? Z bezpečnostního hlediska by bylo lepší povolit jenom to, co opravdu potřebuješ.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod Czuba 27. 1. 2010 22:26

Ja chtěl jenom vědět jak to mám nastavit. Čistě teoreticky. Když jsem je všechny nastavil 1-65535 a chtěl jsem ztahovat z rapidshare z free účtu, tak mi to píše že stahuji atd. Takže jestli si to dobře dávám dohromady, tak veřejnou IP adresu stále nemám. Je to pravda? Tu veřejnou IP adresu budu směřovat na kolegu, jelikož chce stahovat z torrentu z cztorrent nebo tak nějak a musí sdílet, tak proto jsem ji nechal zřídit. A když chce stahovat z torrentu tak mu mám povolit jaký port?
Děkuji

//edit//
teď jsem najel na www.mojeip.cz a tam mi vyskočila IP adresa:
Vaše IP adresa je :
193.85.210.77
Vaše interní IP adresa je :
192.168.4.30
Vaše hostname je :
193.85.210.77

to je veřejnáí IP???
Murphyho zákon : Pokud nezálohuješ, o svá data přijdeš. Pokud zálohuješ, vyskytne se při obnově dat na záložním médiu chyba. Důsledek: o svá data stejně přijdeš...
Czuba
Junior
Uživatelský avatar

Odeslat příspěvekod vladimir 28. 1. 2010 08:10

193.85.xxx.xxx je veřejná a má ji nastavenou ten Mikrotik. 192.168.4.30 je interní adresa na tvém počítači a jsou na ni směřovány příchozí spojení z internetu. Pro Torrent nic jiného nepotřebuješ.

Torentu stačí otevřít (přesměrovat, forwardovat) jeden port. Torrentu se dá nastavit, jaký má používat, takže ať ti kolega řekne, jaký port má nastavený, nebo mu otevři třeba porty UDP 54320 a TCP 54321 a řekni mu, ať si ho/je nastaví (udp port není pro Torrenty nutný, ale je lepší, když je nadefinovaný i ten - ale záleží na tom daném torrent klientovi.).

A jak už jsem psal, musíš zajistit, aby ten kamarád měl pořád tu jednu stejnou IP-adresu, na kterou provedeš přesměrování.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod KyberNet 29. 1. 2010 19:51

Z jineho soudku. Ja si myslim toto:
Provider ti pres svoji sit namapoval IP adresu 80.82.xxx.xx na tvuj router(MicroNet).
To znamena, ze jedine co musis na routeru nastavit je , aby se IP adresa 80.82.xxx.xx prelozila dal do site ne jenom port, ale cela IP z jednoho eth rozhrani do druheho eth rozhrani...
Pote tu verejnou IP adresu 80.82.xxx.xx nastavis primo do jednoho z PC.

Nyni tu verejnou IP adresu nevyuzivas, jelikoz ji nemas nikde zadanou. Momentalne tvuj router prichozi dotaz na tuhle adresu zahodi.Kdezto pokud providerovi dojde dotaz na tuhle verejnou ip adresu preposle ji na tvuj router.
KyberNet
Junior

Odeslat příspěvekod vladimir 29. 1. 2010 20:39

KyberNet píše:Momentalne tvuj router prichozi dotaz na tuhle adresu zahodi.
Ne, příchozí dotaz nezahodí, ale forwarduje.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod KyberNet 29. 1. 2010 20:57

vladimir píše:
KyberNet píše:Momentalne tvuj router prichozi dotaz na tuhle adresu zahodi.
Ne, příchozí dotaz nezahodí, ale forwarduje.

a kampak ten dotaz na 80.82 forwarduje kdyz tu adresu 80.82.x.x nema nikde vyplnenou a zadny z jeho zarizeni o nich nevi a nevi co s ni ma delat? Posledni prvek, ktery vi co s tim je router poskytovatele tedy ten MikroTik
KyberNet
Junior

Odeslat příspěvekod vladimir 29. 1. 2010 21:04

Nastuduj si princip NAT překladu adres a port forwardingu - záznamy o překladu na lokální adresy pochopitelně udržují routery - právě to se nastavuje při konfiguraci port forwardu.

Modelová situace s jedním routerem, který má na WAN veřejnou IP-adresu:

Z internetu přijde paket na vzdáleném portu 80 na tu veřejnou IP-adresu. NAT-router se podívá do své routovací tabulky a zjistí, že spojení na portu 80 má přesměrovat na lokální IP-adresu 192.168.100.100. Změní tedy paketu cílovou adresu na 192.168.100.100 a pošle ji počítači. Ten ji přijme a odpoví, odpověď pošle na výchozí bránu, tedy na NAT-router. Ten zjistí, že paket je určen do internetu a nahradí skutečnou IP-adresu odesílatele 192.168.100.100 veřejnou IP-adresou a paket odešle do internetu.

Právě tato náhrada lokální adresy veřejnou a veřejné adresy lokální je překlad adres a to je důvod, proč počítač vůbec nemusí znát veřejnou IP-adresu, pod kterou vystupuje v internetu - o to se stará NAT-router.
vladimir
Expert
Uživatelský avatar

Odeslat příspěvekod KyberNet 29. 1. 2010 21:59

Ja to chapu, ale nyni je to pouze polovicaty routovani.
Taghle mu to bude fungovat, pokud bude chtit rozjet nejaky www ftp server, ale rozhodne ne uTorrent.
Protoze jestli navaze prvni spojeni tedka jeho PC tedy 192.168.100.100. Tak jede pres branu toho routeru s NAT ( kterej v jeho pripade nema verejnou IP adresu, nyni ma IP adresu 192.168.111.2).Ten ji posle na svoji branu uz na verejnou IP adresu MikroTiku (193.168.x.x). Jenze tam zadny mapovani na porty nejni, takze to nebude fungovat pri zpatecni odpovedi.
My potrebujeme vyuzivat jeho pridelenou IP adresu a tou je 80.82.x.x.
KyberNet
Junior

Odeslat příspěvekod Petr_S 30. 1. 2010 11:10

Teď jsem se v tom trochu ztratil, píše se tu o dvou veřeiných adresách:
193.85.210.77 - Vladislav Heczko - BeskyDnet, v síti GTS Novera (AS2819)
80.82.14x.xx - CoProSys NeTron, s.r.o., Chrudim, v síti CoProSys (AS39906)

To má Czuba připojení ze dvou míst? Nebo jsem něco nepostřehl?
Petr_S
Pokročilý

Odeslat příspěvekod FrisconCZ 30. 12. 2012 17:33

Prosím, mám tento problém už přes 2 roky a furt trvá. Jde nejspíš o zablokovaný porty: Nejde mi např, WOW, CoD: MW3 atd. Prostě mi tam píšou ať si zkontroluju internetový připojení. Nevíte co s tim?
FrisconCZ
Kolemjdoucí

Odeslat příspěvekod Bari007 1. 1. 2013 20:43

Máš veřejnou IP alespoň na routeru? Pokud ano, forwardovat porty jsi zkoušel?
Bari007
VIP uživatel
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků