Nastavení VLAN na switchi

Routery, AP, switche, huby, ethernet

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod I.Indigo 14. 2. 2014 23:37

Řeším na síti následující problém (doufám, že už poslední na dlouhou dobu):

Zdroj internetu od poskytovatele mám přiveden do routeru, DHCP klient si bere IP adresy automaticky z poskytovatelova routeru, dále mám na svém routeru nastaven DHCP server na LAN 1 až LAN 5, v portu LAN 1 mám připojen switch HP V1910 a v něm dále jednotlivé počítače.

Potřebuju, aby se určité skupiny uživatelů vzájemně neviděli v síti. Vytvořil jsme tedy na switchi různé VLANy.

VLAN 1 = internet = nastaveny všechny porty switche jako untagged, protože chci, ať mají přístup všichni
VLAN 2 = skupina 1 nastaveno na 6 portů jako untagged
VLAN 3 = skupina 2 nastaveno zase na jiné porty než VLAN 2
atd.

Problém je te, že se stejně vidí. Internet funguje, ale někde mi něco chybí nebo dělám něco blbě.
Učím se to, a proto budu rád za každou radu.
I.Indigo
Junior

Odeslat příspěvekod soban 15. 2. 2014 08:29

V routeru určitě ty vlany spojíš do jednoho a router vlany asi nerozlišuje?

Prostě musíš vlany nastavit i na routeru podle mě ti mezi vlany asi prochází přes router.
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod fred 15. 2. 2014 09:11

No myslim, ze uživatel nepochopil k cemu jsou VLANy. Jinak by nemohl napsat, ze ma nektere porty zaroven v několika z nich. Chtelo by to nastudovat si aspoň zaklady siti. Když jsou všichni ve vlan1 je jasne ze se vidi. Ta VLAN je uplne zbytecna, router by ti mel routovat net do tech tvých rozdelenych vlanu, aby se nevideli...
Xiaomi Mi9
fred
Junior

Odeslat příspěvekod Bari007 15. 2. 2014 10:28

Na jednom portu můžeš mít VLAN kolik chceš, v tom problém není. Musíš k tomu použít ale tagované VLAN a pro každou VLAN pak používat vlastní síť.
Bari007
VIP uživatel
Uživatelský avatar

Odeslat příspěvekod MiK 15. 2. 2014 13:05

Pořiď si router, který umí VLANy. Na každý port si nastav jednu, většinou tak získáš 4 VLANy. Na administrovatelném switchi si přiřaď porty jednotlivým VLANům. Propoj příslušné VLANy z routeru na odpovídající VLANy ve switchi. Hotovo.
MiK
Junior

Odeslat příspěvekod soban 15. 2. 2014 15:08

Pokud tam máš OpenWRT tak ten vlany umí stačí pouze správně nastavit. I blbý tplink 1043 to umí viz příklady: http://rpc.one.pl/index.php/lista-artyk ... od-openwrt
/----------------------------------------\
| Petr Šobáň |
| Olomouc |
\----------------------------------------/
soban
Pokročilý

Odeslat příspěvekod I.Indigo 15. 2. 2014 18:41

Mám MIKROTIK Cloud Core Router, ale potřebuju těch VLANů více, než je portů na tom Mikrotiku.
I.Indigo
Junior

Odeslat příspěvekod brazda.l 15. 2. 2014 19:13

V tom případě prostě musíš jeden port switche hodit do více VLAN (tagged) a ty samé VLANy vytvořit i na mikrotiku a propojit kabelem. A potom přiřadit jednotlivé přístupové porty (untagged) do VLAN.

A na mikrotiku potom budeš řešit další věci, jako které VLAN mezi sebou komunikovat, které VLAN mohou na internet atd.

Jen je prostě nutné o tom něco vědět, tady ti asi nikdo psát nebude co kde jak přesně nastavit.
PC: Asus P8P67 Pro | Intel Core i5-2500K + Cooler Master Hyper 212+ | Gigabyte GTX560 Ti OC | Kingston 4GB DDR III 1333Mhz | Seagate 500GB | Asus DRW-2014L1T | Enermax 600W NAXN 80+
| HP LP2275w

Notebook: Lenovo Thinkpad R500 2732-7JG
brazda.l
Junior
Uživatelský avatar

Odeslat příspěvekod fred 15. 2. 2014 22:37

Bari007 píše:Na jednom portu můžeš mít VLAN kolik chceš, v tom problém není. Musíš k tomu použít ale tagované VLAN a pro každou VLAN pak používat vlastní síť.
Ale samozrejme ze to v tomhle pripade problém je, jasne tady popisuje ze mají pc pristupovat do vlan1 a nektere z dalších zaroven, coz je při untagged nesmysl a při tagged to nebude access port, na pripojenem pc by musel mit sitovku s podporou vrtualnich adapteru, pro kazdou vlan a navíc by tim vůbec nevyresil oddeleni siti...
Xiaomi Mi9
fred
Junior

Odeslat příspěvekod I.Indigo 15. 2. 2014 23:13

Kdyby někdo z vás věděl o zdroji,kde je to dobře popsáno a vysvětleno, tak budu rád.
Zatím se musím přiznat, že v tom nemám úplně jasno, která varianta je správná a hlavně jaké řešení tedy použít...
I.Indigo
Junior

Odeslat příspěvekod I.Indigo 16. 2. 2014 00:16

Co kdybych to udělal takto:

Na routeru si vytvořím VLANy na ether2:

/interface vlan
add name=VLAN2 vlan-id=2 interface=ether2 disabled=no
add name=VLAN3 vlan-id=3 interface=ether2 disabled=no
add name=VLAN4 vlan-id=4 interface=ether2 disabled=no

Potom jim přidělím IP:
/ip address
add address=10.10.20.1/24 interface=VLAN2
add address=10.10.30.1/24 interface=VLAN3
add address=10.10.40.1/24 interface=VLAN4

Dále propojím port ether2 s jedním portem ve switchi, který bude nakonfigurovaný jako trunk.
Poté nakonfiguruju jednotlivé porty switche podle mé potřeby.
Tedy:
kancelář A bude mít untagged porty 40-48, VLAN2, PVID=2
kancelář B bude mít untagged porty 30-39, VLAN3, PVID=3
kancelář C bude mít untagged porty 25-29, VLAN4, PVID=4

Bude to takto fungovat?
I.Indigo
Junior

Odeslat příspěvekod Kysa 16. 2. 2014 11:02

A nestačilo by ti pouze nastavit různý rozsahy těch sítí a vykašlat se na VLANy?
Kysa
Mírně pokročilý

Odeslat příspěvekod I.Indigo 16. 2. 2014 23:45

Tomu moc dobře nerozumím, jak to přesně myslíš.
I.Indigo
Junior

Odeslat příspěvekod Bari007 17. 2. 2014 09:40

fred:
To máš sice pravdu, ale on přece nechce k jednomu portu s více VLAN připojit koncovou stanici. Z Mikrotiku to půjde do toho switche a ten switch už to pak bude dělit stylem jedna VLAN = jeden port. A takhle to fungovat bude. Sám to takhle provozuji, kdy do dvou portů ve static teamu jde 11 VLAN (každá VLAN má vlastní síť a router) a switch to pak už rozděluje stylem jeden port = jedna VLAN.

I.Indigo:
Jo, to by fungovat mohlo.
Bari007
VIP uživatel
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků