Windows Media Encoder - nefunguje streaming

Záznam a úpravy zvuku a videa na počítači

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod doRm 19. 1. 2007 18:00

Dobrý den,

rozhodl jsem se dát si na svůj web stream z webkamery. Pročetl jsem pár diskuzí a rozhodl jsem se pro Windows Media Encoder. Pomocí průvodce jsem vše nastavil, port jsme si změnil na 7001 a následně jsem ho v nastavení modemu (adsl router Edimax) přesměroval na ip mého počítače (192.168.16.70). Podobné přesměrování jsem už dělal pro DC abych byl active, takže by to mělo být snad správně.

Zkusil jsem zadat adresu mms://localhost:7001, zpustil se WMP a video fungovalo. To samé se stalo když jsem zadal mms://192.168.16.70:7001.

Problém je v tom, chci-li přistupovat k tomu streamu z internetu. Pokud se nepletu, tak by mělo stačit zadat mms://moje ip adresa:7001, ne? Tak přesně tohle jsem udělal a nic. WMP vypsal chybu:

Kód: Vybrat vše
Program Windows Media Player nemůže přehrát soubor, protože došlo k chybě sítě. Server pravděpodobně není dostupný. Ověřte, zda jste připojeni k síti a zda je použité nastavení serveru proxy správné.[/code]


Už vážně nevím co s tim je. Zkusil jsem vytvořit i soubor na internetu http://test2.exweb.org a stále nic. Budu vděčný za každou radu. Děkuji.
Žádný učený z nebe nespadl, ale blbce jako by shazovali.
doRm
Junior

Odeslat příspěvekod lucky17 19. 1. 2007 18:13

No pozrel som si to ale neviem či by sa tam aj malo niečo prehrat...ale okno WMP mi pekne naskocilo len nič neprehravalo....
lucky17
Mírně pokročilý
Uživatelský avatar

Odeslat příspěvekod doRm 19. 1. 2007 18:15

no právě že by se mělo něco přehrát... je tam nastavený http://moje ip:7001/ a nic :(
Žádný učený z nebe nespadl, ale blbce jako by shazovali.
doRm
Junior

Odeslat příspěvekod balik123 19. 1. 2007 18:16

Zdravim,
presne tohle jsem taky resil. Taky jsem se rozhodl pro Windows Media Encoder a taky mam router edimax.
Takze prvni vec kvuli teto veci musis mit pevnou ip adresu.
No a pak se to da prehrat ve win media playeru s tim ze tam zadas normalne http://(tvoji ip) ale pozor musi to byt ip venkovni co ti ukaze treba http://www.whatismyip.com a pak das dvojtecku a za ni cislo portu a melo by to jet...

kdyztak se ptej...

me to jede perfektne....

Balik
PC: Intel, NVIDIA, WD (viz profil)
Notebook: Samsung ATIV Book 9 Plus
Mobil: Samsung Galaxy Note 3
Foto: Nikon 5100 + 18-105 VR + SB-700
balik123
Mírně pokročilý
Uživatelský avatar

Odeslat příspěvekod doRm 19. 1. 2007 18:22

jo, přesně tohle jsem udělal a nic... asi to bude tou ip adresou, ale je to divný. mám net od radiokomunikací, konkrétně premium a píšou že se jedná o pevnou veřejnou statickou IP...
Žádný učený z nebe nespadl, ale blbce jako by shazovali.
doRm
Junior

Odeslat příspěvekod duBeN 19. 1. 2007 18:34

192.168.0.0/16 su privatne ip adresy takze preto to nejde z internetu a kym nebudes mat verejnu ip ani nikdy nepojde.
duBeN
Junior
Uživatelský avatar

Odeslat příspěvekod doRm 19. 1. 2007 18:39

já vím, vždyť já tam taky používám jinou ip ve tvaru 8x.x.x.x kterou mam od radiokomunikací přidělenou jako "veřejnou"
Žádný učený z nebe nespadl, ale blbce jako by shazovali.
doRm
Junior

Odeslat příspěvekod duBeN 19. 1. 2007 19:29

takze router ma verajnu ip a pc privatnu ktora je NATovana? v tom pripade by si mal nastavit na routery port forwarding

http://en.wikipedia.org/wiki/Port_forwarding
duBeN
Junior
Uživatelský avatar

Odeslat příspěvekod doRm 19. 1. 2007 19:31

ano, to jsem udělal s tím portem 7001
Žádný učený z nebe nespadl, ale blbce jako by shazovali.
doRm
Junior

Odeslat příspěvekod duBeN 19. 1. 2007 19:53

aha :) tak potom ti nepomozem :(
duBeN
Junior
Uživatelský avatar


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků