Excel-sčítání

Programy pro práci s textem, tabulkami, prezentacemi

Moderátor: Moderátoři Živě.cz

Odeslat příspěvekod superforum 1. 4. 2010 17:26

Potřeboval bych aby v A1 byla např. hodnota 11 a v B1 hodnota 6 a aby se my v C1 vytvořílo
"11-17" tedy prví číslo pomlčka a součet prvního a druhého čísla
Děkuji
Naposledy upravil superforum dne 1. 4. 2010 17:36, celkově upraveno 1
superforum
Junior

Odeslat příspěvekod Wikan 1. 4. 2010 17:33

A teď ještě jednou a pořádně. Máš tam nesmysly.

-- 1. 4. 2010 18:36 --

Za předokladu, že to druhý A1 má být B1:
=A1&"-"&A1+B1
Wikan
Moderátor
Uživatelský avatar

Odeslat příspěvekod superforum 1. 4. 2010 17:39

Dík tak jsem to myslel.
A šlo by nějak udělat abych do bunky napsal nějaké číslo např.1 a vytvořilo by jse tam nějaké slovo
superforum
Junior

Odeslat příspěvekod Wikan 1. 4. 2010 17:43

Kde?
Wikan
Moderátor
Uživatelský avatar

Odeslat příspěvekod superforum 1. 4. 2010 17:45

Wikan píše:Kde?

napÍší 1 a místo jedničky se zobrazí např.dc
V druhém listu bych měl např. seznam kde budu mít seznam těch čísel a textů.
superforum
Junior

Odeslat příspěvekod Wikan 1. 4. 2010 17:46

Tak to jedině makrem.
Wikan
Moderátor
Uživatelský avatar

Odeslat příspěvekod superforum 1. 4. 2010 17:47

Wikan píše:Tak to jedině makrem.

A jakým?
superforum
Junior

Odeslat příspěvekod Wikan 1. 4. 2010 17:54

Kód: Vybrat vše
Private Sub Worksheet_Change(ByVal Bunka As Range)
  If Bunka.Address = "A1" Then
    If Bunka.Value = 1
      Application.EnableEvents = False
      Bunka.Value = "dc"
      Application.EnableEvents = True
    End If
  End If
End Sub
Wikan
Moderátor
Uživatelský avatar

Odeslat příspěvekod superforum 1. 4. 2010 17:57

Děkuji
superforum
Junior

Odeslat příspěvekod petrfilipi 6. 4. 2010 10:59

Ještě by bylo jedna bezmakrové řešení, a tím je použití funkce SVYHLEDAT. V List1 by byla definice co se má čím přepsat (A1=1, B1=jedna, A2=2, B2=dva, ...) a v List2 by po napsání 1 do buňky A1 byl v buňce B1 vzorec =SVYHLEDAT(A1;List1!A1:B2;2), který by vrátil hodnotu "jedna". Pak by bylo nutné výsledky funkce označit a zkopírovat jinam jako text, aby bylo možné smazat hodnoty ze sloupce A.
Snad mi trochu rozumíte.
Petr Filipi
petrfilipi
Junior


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků